summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzzy-ac2021-09-19 01:26:45 +0800
committerzzy-ac2021-09-19 01:26:45 +0800
commit2b90a3003fcf66f64d33a7151fd89f7687aea56e (patch)
tree67dd9e62b7282422f7f0b8e446231ba95f18a52f
downloadaur-2b90a3003fcf66f64d33a7151fd89f7687aea56e.tar.gz
creat electronic-wechat-zzy-ac
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4c5eaa981ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = electronic-wechat-zzy-ac
+ pkgdesc = A better WeChat on macOS and Linux. Built with Electron. Maintained by kooritea
+ pkgver = 2.3.1.1
+ pkgrel = 1
+ url = https://github.com/zzy-ac/electronic-wechat
+ arch = x86_64
+ license = MIT
+ depends = nss
+ depends = gtk3
+ depends = libxss
+ depends = electron4-bin
+ conflicts = electronic-wechat
+ conflicts = electronic-wechat-git
+ replaces = electronic-wechat
+ replaces = electronic-wechat-git
+ source = https://github.com/zzy-ac/electronic-wechat/releases/download/v2.3.1.1/electronic-wechat-linux-x64.tar.gz
+ md5sums = 965fdff3701fa8c8be9be1353659e349
+
+pkgname = electronic-wechat-zzy-ac
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12510c5f1c69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+# Maintainer: xgdgsc <xgdgsc at gmail dot com>
+
+pkgname=electronic-wechat-zzy-ac
+pkgver=2.3.1.1
+pkgrel=1
+pkgdesc="A better WeChat on macOS and Linux. Built with Electron. Maintained by kooritea"
+url=https://github.com/zzy-ac/electronic-wechat
+arch=(x86_64)
+replaces=('electronic-wechat' 'electronic-wechat-git')
+conflicts=('electronic-wechat' 'electronic-wechat-git')
+depends=('nss' 'gtk3' 'libxss' 'electron4-bin')
+license=('MIT')
+md5sums=('965fdff3701fa8c8be9be1353659e349')
+
+source=("https://github.com/zzy-ac/electronic-wechat/releases/download/v${pkgver}/electronic-wechat-linux-x64.tar.gz")
+
+
+package() {
+ mkdir -p "${pkgdir}/opt/electronic-wechat-linux-x64"
+
+ install -dm755 "${pkgdir}"/usr/share/applications
+ cp electronic-wechat-linux-x64/electronic-wechat.desktop "${pkgdir}"/usr/share/applications
+
+ cd electronic-wechat-linux-x64
+ install -dm755 "${pkgdir}/opt/electronic-wechat-linux-x64"
+ mv * "${pkgdir}/opt/electronic-wechat-linux-x64"
+
+ install -dm755 "${pkgdir}"/usr/bin
+ ln -s /opt/electronic-wechat-linux-x64/electronic-wechat "${pkgdir}/usr/bin/electronic-wechat"
+}