summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-12 09:58:48 +0800
committerzxp198210052023-07-12 09:58:48 +0800
commit14ad390cf77ca5dbc86c91355e7d23bcd942412f (patch)
tree40a9ba7320416536b905d49f766888043f637144
parent4bfe5af1e4a16722d2927331ded7cac2f64e2917 (diff)
downloadaur-14ad390cf77ca5dbc86c91355e7d23bcd942412f.tar.gz
first release
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--electronim.sh4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c4d56833ea3..c633cce2b7e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,6 @@ pkgbase = electronim-bin
source = electronim-0.0.93.AppImage::https://github.com/manusa/electronim/releases/download/v0.0.93/electronim-linux-x86_64.AppImage
source = electronim.sh
sha256sums = f934e20cab3054c6600e6001f4e128874271e04aa6b6a9a8bd3d5f56a0274d68
- sha256sums = 86f66d12d6f318431fc7124ccd7c14246b52cf2c96322941c813ff476bcd7433
+ sha256sums = 2d3af84a7c93ddaf4670e27a43f981a1871188f4a2e80e29832236f9d3437da4
pkgname = electronim-bin
diff --git a/PKGBUILD b/PKGBUILD
index 05b80d080ab8..8a1071e88b5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ depends=('electron25' 'gcc-libs' 'glibc')
source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${CARCH}.AppImage"
"${pkgname%-bin}.sh")
sha256sums=('f934e20cab3054c6600e6001f4e128874271e04aa6b6a9a8bd3d5f56a0274d68'
- '86f66d12d6f318431fc7124ccd7c14246b52cf2c96322941c813ff476bcd7433')
+ '2d3af84a7c93ddaf4670e27a43f981a1871188f4a2e80e29832236f9d3437da4')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/electronim.sh b/electronim.sh
index 6f3caef6d2e8..9c3255797307 100644
--- a/electronim.sh
+++ b/electronim.sh
@@ -1,6 +1,6 @@
#!/bin/bash
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron /opt/electronim/app.asar "$@"
+ exec electron25 /opt/electronim/app.asar "$@"
else
- exec electron --no-sandbox /opt/electronim/app.asar "$@"
+ exec electron25 --no-sandbox /opt/electronim/app.asar "$@"
fi \ No newline at end of file