summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-02 19:13:58 +0800
committerzxp198210052023-09-02 19:13:58 +0800
commit1f079a68d185b5d2f97f7569e115d9665dea744a (patch)
treea0bd5439b67835a170fa06fa4b3a9700f275bd40
parent180d56db6cd15f2d7a45a79282eaffccd6e16d65 (diff)
downloadaur-1f079a68d185b5d2f97f7569e115d9665dea744a.tar.gz
update to 0.0.95
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6250fe1ea36..d7d89c378cd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = electronim-bin
pkgdesc = A Self Contained Desktop Version Of electronim Made With Electron
- pkgver = 0.0.93
- pkgrel = 3
+ pkgver = 0.0.95
+ pkgrel = 1
url = https://github.com/manusa/electronim
arch = x86_64
license = Apache
depends = bash
depends = electron25
- depends = gcc-libs
- depends = glibc
- provides = electronim=0.0.93
+ provides = electronim=0.0.95
conflicts = electronim
- source = electronim-0.0.93.AppImage::https://github.com/manusa/electronim/releases/download/v0.0.93/electronim-linux-x86_64.AppImage
+ source = electronim-0.0.95.AppImage::https://github.com/manusa/electronim/releases/download/v0.0.95/electronim-linux-x86_64.AppImage
source = electronim.sh
- sha256sums = f934e20cab3054c6600e6001f4e128874271e04aa6b6a9a8bd3d5f56a0274d68
+ sha256sums = 69f045bdc81ce3ae484ff9c0d7bd2e2e5e06489187b74f345ede83ae55be0148
sha256sums = be837ef65c85241d02a30b6fc7693f7b66a59963521f657335ec73212e2ee020
pkgname = electronim-bin
diff --git a/PKGBUILD b/PKGBUILD
index aed4d66f1fce..2fc758f98e26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=electronim-bin
-pkgver=0.0.93
-pkgrel=3
+pkgver=0.0.95
+pkgrel=1
pkgdesc="A Self Contained Desktop Version Of electronim Made With Electron"
arch=('x86_64')
url="https://github.com/manusa/electronim"
license=('Apache')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron25' 'gcc-libs' 'glibc')
+depends=('bash' 'electron25')
source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${CARCH}.AppImage"
"${pkgname%-bin}.sh")
-sha256sums=('f934e20cab3054c6600e6001f4e128874271e04aa6b6a9a8bd3d5f56a0274d68'
+sha256sums=('69f045bdc81ce3ae484ff9c0d7bd2e2e5e06489187b74f345ede83ae55be0148'
'be837ef65c85241d02a30b6fc7693f7b66a59963521f657335ec73212e2ee020')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} \;
} \ No newline at end of file