summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-08 21:29:36 +0800
committerzxp198210052024-01-08 21:29:36 +0800
commit32a81a2ed9edcf2bec82800c5b0029d8c2d702eb (patch)
tree80db6c540e7cde890975e6041ee779fc49ea0e92
parent0eb3ff7961637ef9274a279db8e06d4a527a4625 (diff)
downloadaur-32a81a2ed9edcf2bec82800c5b0029d8c2d702eb.tar.gz
update to 0.0.98
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD17
-rw-r--r--electronim.sh22
3 files changed, 27 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80bcf5eb1386..5ef50641e131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
pkgbase = electronim-bin
pkgdesc = Electron based multi IM (Instant Messaging) client
- pkgver = 0.0.97
- pkgrel = 2
+ pkgver = 0.0.98
+ pkgrel = 1
url = https://github.com/manusa/electronim
arch = x86_64
license = Apache
makedepends = squashfuse
- depends = electron26
+ depends = electron27
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
- depends = gdk-pixbuf2
- depends = libxext
- depends = libx11
- provides = electronim=0.0.97
+ provides = electronim=0.0.98
conflicts = electronim
- source = electronim-0.0.97.AppImage::https://github.com/manusa/electronim/releases/download/v0.0.97/electronim-linux-x86_64.AppImage
+ source = electronim-0.0.98.AppImage::https://github.com/manusa/electronim/releases/download/v0.0.98/electronim-linux-x86_64.AppImage
source = electronim.sh
- sha256sums = 1e61707419623f671f9a9347f415226bc672d1bbcd6ae61b0e5b5e7b2027919f
- sha256sums = 69ba5c2a4361af98fba91a6aaa908accc7ff794973cfdaa69aa2c9a5117b9c1f
+ sha256sums = e9673b4cbebb7c30ba0f76f760b32d27d524000519692a36a61a9d3cc626bef7
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = electronim-bin
diff --git a/PKGBUILD b/PKGBUILD
index 342e974bff81..6f12b8d72f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=electronim-bin
-pkgver=0.0.97
-_electronversion=26
-pkgrel=2
+pkgver=0.0.98
+_electronversion=27
+pkgrel=1
pkgdesc="Electron based multi IM (Instant Messaging) client"
arch=('x86_64')
url="https://github.com/manusa/electronim"
@@ -11,12 +11,9 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
- 'gdk-pixbuf2'
- 'libxext'
- 'libx11'
)
makedepends=(
'squashfuse'
@@ -25,13 +22,13 @@ source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${CARCH}.AppImage"
"${pkgname%-bin}.sh"
)
-sha256sums=('1e61707419623f671f9a9347f415226bc672d1bbcd6ae61b0e5b5e7b2027919f'
- '69ba5c2a4361af98fba91a6aaa908accc7ff794973cfdaa69aa2c9a5117b9c1f')
+sha256sums=('e9673b4cbebb7c30ba0f76f760b32d27d524000519692a36a61a9d3cc626bef7'
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -i "s|@electronversion@|${_electronversion}|" "$srcdir/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/electronim.sh b/electronim.sh
index 7edfae106714..aacd8f895847 100644
--- a/electronim.sh
+++ b/electronim.sh
@@ -1,13 +1,15 @@
-#!/bin/bash
-APPDIR="/usr/lib/electronim"
-export PATH="${APPDIR}:${PATH}"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
-export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd $APPDIR
- exec electron@electronversion@ ${_ASAR} "$@"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd $APPDIR
- exec electron@electronversion@ ${_ASAR} --no-sandbox "$@"
-fi \ No newline at end of file
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+fi
+exit \ No newline at end of file