summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-12 09:58:01 +0800
committerzxp198210052023-07-12 09:58:01 +0800
commitab8e98627356915ad99d7eeebd30c0c7e7322e32 (patch)
treeb5d63fc5759759b23cf71814cd051e01369e05e2
downloadaur-ab8e98627356915ad99d7eeebd30c0c7e7322e32.tar.gz
first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c4d56833ea3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = electronim-bin
+ pkgdesc = A Self Contained Desktop Version Of electronim Made With Electron
+ pkgver = 0.0.93
+ pkgrel = 1
+ url = https://github.com/manusa/electronim
+ arch = x86_64
+ license = Apache
+ depends = electron25
+ depends = gcc-libs
+ depends = glibc
+ conflicts = electronim
+ source = electronim-0.0.93.AppImage::https://github.com/manusa/electronim/releases/download/v0.0.93/electronim-linux-x86_64.AppImage
+ source = electronim.sh
+ sha256sums = f934e20cab3054c6600e6001f4e128874271e04aa6b6a9a8bd3d5f56a0274d68
+ sha256sums = 86f66d12d6f318431fc7124ccd7c14246b52cf2c96322941c813ff476bcd7433
+
+pkgname = electronim-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05b80d080ab8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=electronim-bin
+pkgver=0.0.93
+pkgrel=1
+pkgdesc="A Self Contained Desktop Version Of electronim Made With Electron"
+arch=('x86_64')
+url="https://github.com/manusa/electronim"
+license=('Apache')
+conflicts=("${pkgname%-bin}")
+depends=('electron25' 'gcc-libs' 'glibc')
+source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${CARCH}.AppImage"
+ "${pkgname%-bin}.sh")
+sha256sums=('f934e20cab3054c6600e6001f4e128874271e04aa6b6a9a8bd3d5f56a0274d68'
+ '86f66d12d6f318431fc7124ccd7c14246b52cf2c96322941c813ff476bcd7433')
+prepare() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} \;
+} \ No newline at end of file