summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 15:28:03 +0800
committerzxp198210052024-03-22 15:28:03 +0800
commite0e107ded602923f010bd71280c0bf15a89e39b6 (patch)
treebc8771c11dc5fbc0873bf4e82d98c84a32397339
parent8c6b6276735ef31ae7034708a81a447e507c091e (diff)
downloadaur-e0e107ded602923f010bd71280c0bf15a89e39b6.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--electronim.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b197c188acd..7dc5cb0581df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electronim-bin
pkgdesc = Electron based multi IM (Instant Messaging) client
pkgver = 0.0.100
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/manusa/electronim
arch = x86_64
license = Apache-2.0
@@ -12,6 +12,6 @@ pkgbase = electronim-bin
source = electronim-0.0.100.AppImage::https://github.com/manusa/electronim/releases/download/v0.0.100/electronim-linux-x86_64.AppImage
source = electronim.sh
sha256sums = ff2201b97274c59766ae491bb266583344456e3864c1a857f4fd7d9e1523ccde
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = electronim-bin
diff --git a/PKGBUILD b/PKGBUILD
index e8370985ed56..c0ec7153cd85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=electronim-bin
pkgver=0.0.100
_electronversion=28
-pkgrel=1
+pkgrel=2
pkgdesc="Electron based multi IM (Instant Messaging) client"
arch=('x86_64')
url="https://github.com/manusa/electronim"
@@ -20,11 +20,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('ff2201b97274c59766ae491bb266583344456e3864c1a857f4fd7d9e1523ccde'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/electronim.sh b/electronim.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/electronim.sh
+++ b/electronim.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file