summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOirio Joshi2019-03-13 17:12:55 +0100
committerOirio Joshi2019-03-13 17:12:55 +0100
commit6e9d93dd5df0238cbd2f16f5cb250dc890d56788 (patch)
treedae99a4028a47f5960d9f0faae3ce3aad888015f
downloadaur-6e9d93dd5df0238cbd2f16f5cb250dc890d56788.tar.gz
version 3.0.0
-rw-r--r--.SRCINFO34
-rw-r--r--LICENSE21
-rwxr-xr-xPKGBUILD27
-rw-r--r--electronmail-bin.install16
4 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..418cc5dded55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = electronmail-bin
+ pkgdesc = Unofficial desktop app for several E2E encrypted email providers
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/vladimiry/ElectronMail
+ install = electronmail-bin.install
+ arch = x86_64
+ license = MIT
+ depends = c-ares
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ depends = libnotify
+ depends = libappindicator-gtk2
+ depends = libappindicator-gtk3
+ depends = gconf
+ depends = gnome-keyring
+ provides = electronmail
+ conflicts = electronmail
+ source = https://github.com/vladimiry/ElectronMail/releases/download/v3.0.0/electron-mail-3.0.0-linux-x64.pacman
+ source = LICENSE
+ md5sums = 443a025c176f955ef1ce3c61840d9186
+ md5sums = fc680045f40b19ce3c3e771aeb08bbd3
+
+pkgname = electronmail-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4294394c2af9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Vladimir Yakovlev
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..fc25bb408f54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Oirio Joshi <joshirio@protonmail.com>
+# Author: Vladimir Yakovlev <desktop-app@protonmail.ch>
+pkgname=electronmail-bin
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Unofficial desktop app for several E2E encrypted email providers"
+arch=('x86_64')
+url="https://github.com/vladimiry/ElectronMail"
+license=('MIT')
+# add libappindicator-sharp to the depends array if you are fine with mono deps
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk2' 'libappindicator-gtk3' 'gconf' 'gnome-keyring')
+conflicts=('electronmail')
+provides=('electronmail')
+install="${pkgname}.install"
+source=("https://github.com/vladimiry/ElectronMail/releases/download/v${pkgver}/electron-mail-${pkgver}-linux-x64.pacman" 'LICENSE')
+md5sums=('443a025c176f955ef1ce3c61840d9186'
+ 'fc680045f40b19ce3c3e771aeb08bbd3')
+
+package() {
+ cd "$srcdir"
+
+ cp -R "${srcdir}/usr/" "${pkgdir}/usr/"
+ cp -R "${srcdir}/opt/" "${pkgdir}/opt/"
+
+ # License
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/electronmail-bin.install b/electronmail-bin.install
new file mode 100644
index 000000000000..f4be1ffbc796
--- /dev/null
+++ b/electronmail-bin.install
@@ -0,0 +1,16 @@
+post_install() {
+ :
+#!/bin/bash
+
+# Link to the binary
+ln -sf '/opt/ElectronMail/electron-mail' '/usr/local/bin/electron-mail'
+
+}
+post_remove() {
+ :
+#!/bin/bash
+
+# Delete the link to the binary
+rm -f '/usr/local/bin/electron-mail'
+
+}