summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2020-12-01 15:46:14 +0100
committerTimothy Redaelli2020-12-01 15:46:23 +0100
commit7b01d468d34ba07bc1c2b95cc200ae0f4771db74 (patch)
treee1959d236f2929856202a7ef2c93d1c5a3ee9c53
parentc355f23659a2147bc129450ab6cb584d61228ede (diff)
downloadaur-7b01d468d34ba07bc1c2b95cc200ae0f4771db74.tar.gz
Link dynamically with rocksdb
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1be99d5e1b7..5852c1f14d01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = electrs
makedepends = cmake
makedepends = rust
depends = gcc-libs
+ depends = rocksdb
source = git+https://github.com/romanz/electrs.git#tag=v0.8.6
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index da20b1756f51..0da28f50c53e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@ pkgdesc="An efficient re-implementation of Electrum Server in Rust"
arch=(x86_64)
url="https://github.com/romanz/electrs"
license=('MIT')
-depends=('gcc-libs')
+depends=('gcc-libs' 'rocksdb')
makedepends=('git' 'clang' 'cmake' 'rust')
source=("git+https://github.com/romanz/electrs.git#tag=v$pkgver")
md5sums=('SKIP')
build() {
cd "$pkgname"
- cargo build --release --locked
+ ROCKSDB_INCLUDE_DIR=/usr/include ROCKSDB_LIB_DIR=/usr/lib cargo build --locked --no-default-features --release
}
check() {