summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2019-02-06 15:33:32 +1100
committerLuis Aranguren2019-02-06 15:33:32 +1100
commit58d8a2ad46b0cd5d6d33827d26d341add96f36d0 (patch)
treed958ddc786eed46380309e80af42b9dca0e57161
parent93d8881c6e5a5cf1d081070683e7f57d879b2cc7 (diff)
downloadaur-58d8a2ad46b0cd5d6d33827d26d341add96f36d0.tar.gz
update pkgrel to 2, removal undocumented subroutines https://bugs.archlinux.org/task/43502
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5d8b4b63818..b64327eae16f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = electrum-git
pkgdesc = Lightweight Bitcoin wallet
pkgver = 20190205
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/spesmilo/electrum
install = electrum.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index df1aa70bc889..595b079cb96d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=electrum-git
pkgver=20190205
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight Bitcoin wallet"
arch=('any')
depends=('hicolor-icon-theme'
@@ -70,19 +70,19 @@ pkgver() {
build() {
cd ${pkgname%-git}
- msg2 'Initializing git submodule...'
+ echo 'Initializing git submodule...'
git submodule init
- msg2 'Compiling protobuf description file...'
+ echo 'Compiling protobuf description file...'
protoc \
--proto_path=electrum \
--python_out=electrum \
electrum/paymentrequest.proto
- msg2 'Creating translations...'
+ echo 'Creating translations...'
python contrib/make_locale
- msg2 'Building...'
+ echo 'Building...'
python setup.py build
}
@@ -93,14 +93,14 @@ check() {
_pyver="$(python -c \
'import platform; print("%s%s" % platform.python_version_tuple()[0:2])')"
- msg2 'Testing...'
+ echo 'Testing...'
tox -e "py$_pyver"
}
package() {
cd ${pkgname%-git}
- msg2 'Installing...'
+ echo 'Installing...'
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 AUTHORS README.rst RELEASE-NOTES -t "$pkgdir"/usr/share/doc/$pkgname