summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgruve-p2022-06-07 10:45:02 +0000
committergruve-p2022-06-07 10:45:02 +0000
commit5e88aea8c39872e5aeb00b171b0f43274d0f1923 (patch)
treefcd44a5f514a1086c310a77fbece496bf0fc0e66
downloadaur-5e88aea8c39872e5aeb00b171b0f43274d0f1923.tar.gz
Add electrum-grs pkgbase
-rw-r--r--.SRCINFO56
-rw-r--r--PKGBUILD79
-rw-r--r--electrum-grs.install16
3 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfbe5841944a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,56 @@
+pkgbase = electrum-grs
+ pkgdesc = Lightweight Groestlcoin wallet
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = https://github.com/groestlcoin/electrum-grs
+ install = electrum-grs.install
+ arch = any
+ license = MIT
+ makedepends = gettext
+ makedepends = git
+ makedepends = protobuf
+ makedepends = python-pycurl
+ makedepends = python-setuptools
+ depends = hicolor-icon-theme
+ depends = libsecp256k1
+ depends = python
+ depends = python-ecdsa
+ depends = python-qrcode
+ depends = python-protobuf
+ depends = python-dnspython
+ depends = python-qdarkstyle
+ depends = python-aiorpcx
+ depends = python-aiohttp
+ depends = python-aiohttp-socks
+ depends = python-certifi
+ depends = python-bitstring
+ depends = python-attrs
+ depends = python-cryptography
+ depends = python-requests
+ depends = python-six
+ depends = python-pyqt5
+ depends = qt5-base
+ depends = python-groestlcoin_hash
+ optdepends = desktop-file-utils: update desktop icon
+ optdepends = gtk-update-icon-cache: update desktop icon
+ optdepends = python-hidapi: Digital Bitbox hardware wallet support
+ optdepends = python-trezor: Trezor hardware wallet support
+ optdepends = python-safet: Archos Safe-T hardware wallet support
+ optdepends = python-keepkey: KeepKey hardware wallet support
+ optdepends = python-btchip: Ledger hardware wallet support
+ optdepends = python-ckcc-protocol: Coldcard wallet hardware support
+ optdepends = python-bitbox02: BitBox wallet hardware support
+ optdepends = python-cbor: Blockstream Jade hardware wallet communication
+ optdepends = python-pyserial: Blockstream Jade hardware wallet serial port extension
+ optdepends = python-matplotlib: plot transaction history in graphical mode
+ optdepends = python-rpyc: send commands to Electrum Python console from an external script
+ optdepends = xdg-utils: update desktop icon
+ optdepends = python-amodem: air-gapped transaction signing over audio modem
+ optdepends = zbar: QR code reading support
+ source = https://github.com/Groestlcoin/electrum-grs/releases/download/v4.2.0/Electrum-grs-4.2.0.tar.gz
+ source = Electrum-grs-4.2.0.tar.gz.asc::https://github.com/Groestlcoin/electrum-grs/releases/download/v4.2.0/Electrum-grs-4.2.0.tar.gz.asc
+ validpgpkeys = 287AE4CA1187C68C08B49CB2D11BD4F33F1DB499
+ sha256sums = 196de3e79e785a32acf54ebfe38f9ba74e615248d0b68a1a26533526ff8e48db
+ sha256sums = c4fbe827e40d4fb25483dde89a9a18943fa0e54341a7608ef3583fed61ddda04
+
+pkgname = electrum-grs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce9bc1bad476
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: groestlcoin <groestlcoin@gmail.com>
+
+pkgname=electrum-grs
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="Lightweight Groestlcoin wallet"
+arch=('any')
+url="https://github.com/groestlcoin/electrum-grs"
+license=('MIT')
+depends=('hicolor-icon-theme'
+ 'libsecp256k1'
+ 'python'
+ 'python-ecdsa'
+ 'python-qrcode'
+ 'python-protobuf'
+ 'python-dnspython'
+ 'python-qdarkstyle'
+ 'python-aiorpcx'
+ 'python-aiohttp'
+ 'python-aiohttp-socks'
+ 'python-certifi'
+ 'python-bitstring'
+ 'python-attrs'
+ 'python-cryptography'
+ 'python-requests'
+ 'python-six'
+ 'python-pyqt5'
+ 'qt5-base'
+ 'python-groestlcoin_hash')
+makedepends=('gettext'
+ 'git'
+ 'protobuf'
+ 'python-pycurl'
+ 'python-setuptools')
+optdepends=('desktop-file-utils: update desktop icon'
+ 'gtk-update-icon-cache: update desktop icon'
+ 'python-hidapi: Digital Bitbox hardware wallet support'
+ 'python-trezor: Trezor hardware wallet support'
+ 'python-safet: Archos Safe-T hardware wallet support'
+ 'python-keepkey: KeepKey hardware wallet support'
+ 'python-btchip: Ledger hardware wallet support'
+ 'python-ckcc-protocol: Coldcard wallet hardware support'
+ 'python-bitbox02: BitBox wallet hardware support'
+ 'python-cbor: Blockstream Jade hardware wallet communication'
+ 'python-pyserial: Blockstream Jade hardware wallet serial port extension'
+ 'python-matplotlib: plot transaction history in graphical mode'
+ 'python-rpyc: send commands to Electrum Python console from an external script'
+ 'xdg-utils: update desktop icon'
+ 'python-amodem: air-gapped transaction signing over audio modem'
+ 'zbar: QR code reading support')
+source=("https://github.com/Groestlcoin/electrum-grs/releases/download/v${pkgver}/Electrum-grs-${pkgver}.tar.gz"
+ "Electrum-grs-${pkgver}.tar.gz.asc::https://github.com/Groestlcoin/electrum-grs/releases/download/v${pkgver}/Electrum-grs-${pkgver}.tar.gz.asc")
+sha256sums=('196de3e79e785a32acf54ebfe38f9ba74e615248d0b68a1a26533526ff8e48db'
+ 'c4fbe827e40d4fb25483dde89a9a18943fa0e54341a7608ef3583fed61ddda04')
+validpgpkeys=('287AE4CA1187C68C08B49CB2D11BD4F33F1DB499')
+install=electrum-grs.install
+
+build() {
+ cd "Electrum-grs-${pkgver}"
+
+ echo 'Compiling protobuf description file...'
+ protoc \
+ --proto_path=electrum_grs \
+ --python_out=electrum_grs \
+ electrum_grs/paymentrequest.proto
+
+ echo 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "Electrum-grs-${pkgver}"
+
+ echo 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 AUTHORS README.rst RELEASE-NOTES -t "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm644 LICENCE -t "$pkgdir"/usr/share/licenses/$pkgname
+}
diff --git a/electrum-grs.install b/electrum-grs.install
new file mode 100644
index 000000000000..b9649c46769a
--- /dev/null
+++ b/electrum-grs.install
@@ -0,0 +1,16 @@
+post_install() {
+ ( [[ -x /usr/bin/update-desktop-database ]] && update-desktop-database -q ) \
+ || true
+ ( [[ -x /usr/bin/xdg-icon-resource ]] && xdg-icon-resource forceupdate --theme hicolor ) \
+ || true
+ ( [[ -x /usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -f -q /usr/share/icons/hicolor ) \
+ || true
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}