summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2022-05-31 11:21:27 +1000
committerLuis Aranguren2022-05-31 11:21:27 +1000
commitc93c0175116d83417fe069544da07c93f64278ff (patch)
tree8d84904dd3fee278b0ce0662cbc6b9ebf77e3d25
parent0883d8f6a9ee835234f41e58e8adc6e183c967ff (diff)
downloadaur-c93c0175116d83417fe069544da07c93f64278ff.tar.gz
removed unused dependencies, added support for BitBox and Jade hardware wallets
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e7009470dcf..4589f81c7cc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,12 +15,8 @@ pkgbase = electrum-ltc-git
depends = libsecp256k1
depends = python
depends = python-dnspython
- depends = python-ecdsa
- depends = python-jsonrpclib-pelix
depends = python-protobuf
- depends = python-pyaes
depends = python-pyqt5
- depends = python-pysocks
depends = python-qdarkstyle
depends = python-qrcode
depends = python-requests
@@ -32,6 +28,7 @@ pkgbase = electrum-ltc-git
depends = python-aiohttp
depends = python-scrypt
depends = qt5-base
+ depends = python-cryptography
depends = python-bitstring
depends = python-attrs
optdepends = desktop-file-utils: update desktop icon
@@ -40,12 +37,14 @@ pkgbase = electrum-ltc-git
optdepends = python-btchip: Ledger hardware wallet support
optdepends = python-ckcc-protocol: Coldcard wallet hardware support
optdepends = python-hidapi: Digital Bitbox hardware wallet support
- optdepends = python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes
optdepends = python-keepkey: KeepKey hardware wallet support
optdepends = python-matplotlib: plot transaction history in graphical mode
optdepends = python-rpyc: send commands to Electrum Python console from an external script
optdepends = python-safet: Archos Safe-T hardware wallet support
optdepends = python-trezor: Trezor hardware wallet support
+ optdepends = python-bitbox02: BitBox wallet hardware support
+ optdepends = python-cbor: Blockstream Jade hardware wallet communication
+ optdepends = python-pyserial: Blockstream Jade hardware wallet serial port extension
optdepends = xdg-utils: update desktop icon
optdepends = zbar: QR code reading support
provides = electrum-ltc
diff --git a/PKGBUILD b/PKGBUILD
index 2f5fd34f8f67..d43e08176b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,8 @@ depends=('hicolor-icon-theme'
'libsecp256k1'
'python'
'python-dnspython'
- 'python-ecdsa'
- 'python-jsonrpclib-pelix'
'python-protobuf'
- 'python-pyaes'
'python-pyqt5'
- 'python-pysocks'
'python-qdarkstyle'
'python-qrcode'
'python-requests'
@@ -29,6 +25,7 @@ depends=('hicolor-icon-theme'
'python-aiohttp'
'python-scrypt'
'qt5-base'
+ 'python-cryptography'
'python-bitstring'
'python-attrs')
checkdepends=('python-tox')
@@ -43,12 +40,14 @@ optdepends=('desktop-file-utils: update desktop icon'
'python-btchip: Ledger hardware wallet support'
'python-ckcc-protocol: Coldcard wallet hardware support'
'python-hidapi: Digital Bitbox hardware wallet support'
- 'python-pycryptodomex: use PyCryptodome AES implementation instead of pyaes'
'python-keepkey: KeepKey hardware wallet support'
'python-matplotlib: plot transaction history in graphical mode'
'python-rpyc: send commands to Electrum Python console from an external script'
'python-safet: Archos Safe-T hardware wallet support'
'python-trezor: Trezor hardware wallet support'
+ 'python-bitbox02: BitBox wallet hardware support'
+ 'python-cbor: Blockstream Jade hardware wallet communication'
+ 'python-pyserial: Blockstream Jade hardware wallet serial port extension'
'xdg-utils: update desktop icon'
'zbar: QR code reading support')
source=(git+https://github.com/pooler/electrum-ltc)