summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-08 00:40:56 +0200
committerhaawda2018-04-08 00:40:56 +0200
commit8eb1f0bd27cbcdd0e6bf2ed2f1a336d623af4565 (patch)
tree182ca9c03e50c442af4760efe88ee6ea6ea37e85
parent9f0a8e9d3189359f5487587144043ad56a9c7137 (diff)
downloadaur-8eb1f0bd27cbcdd0e6bf2ed2f1a336d623af4565.tar.gz
update, some dependency fixes
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ff3a6af43e2..2d0df2738dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,7 @@ pkgbase = elektra
depends = curl
depends = boost
depends = swig
+ depends = libuv
optdepends = ruby: for ruby bindings
optdepends = python2: for python2-bindings
optdepends = xerces-c: for python2-bindings
diff --git a/PKGBUILD b/PKGBUILD
index a869a3cd531b..2cc8d235e1ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@ pkgdesc="A universal hierarchical configuration store"
url="https://www.libelektra.org"
license=('custom:BSD')
arch=('i686' 'x86_64')
-depends=('yajl' 'qt5-base' 'python' 'curl' 'boost' 'swig')
+depends=('yajl' 'qt5-base' 'python' 'curl' 'boost' 'swig' 'libuv')
optdepends=('ruby: for ruby bindings'
- 'python2: for python2-bindings'
- 'xerces-c: for python2-bindings'
- 'lua: for lua bindings'
- 'libgit2: for git support')
+ 'python2: for python2-bindings'
+ 'xerces-c: for python2-bindings'
+ 'lua: for lua bindings'
+ 'libgit2: for git support')
makedepends=('docbook-xsl' 'cmake' 'doxygen')
source=(https://github.com/ElektraInitiative/libelektra/archive/$pkgver.tar.gz)
sha256sums=('f9322cffa2f57f15805c97fd1b11277212cefc73058c6ca579fa79ab0e76aabf')
@@ -37,5 +37,5 @@ build() {
package() {
cd lib$pkgname-$pkgver/build
make DESTDIR="$pkgdir" install
- install -Dm644 ../LICENSE.md "$pkgdir"/usr/share/licenses/LICENSE.md
+ install -Dm644 ../LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md
}