summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-03 06:53:16 +0200
committerhaawda2018-04-03 06:53:16 +0200
commit9f0a8e9d3189359f5487587144043ad56a9c7137 (patch)
tree1ab760a56f3a23e7801e2c7c0aa853ec18392c9c
parentc80548ab86f4cadaa8b9541a01b9991786866d4c (diff)
downloadaur-9f0a8e9d3189359f5487587144043ad56a9c7137.tar.gz
update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 35 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb71e65c3eb3..4ff3a6af43e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
pkgbase = elektra
- pkgdesc = Elektra is a universal hierarchical configuration store
- pkgver = 0.8.21
+ pkgdesc = A universal hierarchical configuration store
+ pkgver = 0.8.22
pkgrel = 1
url = https://www.libelektra.org
arch = i686
arch = x86_64
- arch = lua
- license = BSD
+ license = custom:BSD
makedepends = docbook-xsl
makedepends = cmake
makedepends = doxygen
- depends = libxml2
depends = yajl
depends = qt5-base
depends = python
depends = curl
depends = boost
- depends = dbus
depends = swig
- source = https://github.com/ElektraInitiative/libelektra/archive/0.8.21.tar.gz
- sha256sums = 4a0c226efebb51f6639ab30a49c4eacfb0a9ba7d9c8c7449a788fe8a42222c3f
+ optdepends = ruby: for ruby bindings
+ optdepends = python2: for python2-bindings
+ optdepends = xerces-c: for python2-bindings
+ optdepends = lua: for lua bindings
+ optdepends = libgit2: for git support
+ source = https://github.com/ElektraInitiative/libelektra/archive/0.8.22.tar.gz
+ sha256sums = f9322cffa2f57f15805c97fd1b11277212cefc73058c6ca579fa79ab0e76aabf
pkgname = elektra
diff --git a/PKGBUILD b/PKGBUILD
index 14af3818ffcc..a869a3cd531b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,41 @@
-# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=elektra
-pkgver=0.8.21
+pkgver=0.8.22
pkgrel=1
-pkgdesc="Elektra is a universal hierarchical configuration store"
+pkgdesc="A universal hierarchical configuration store"
url="https://www.libelektra.org"
-license=("BSD")
-arch=('i686' 'x86_64' 'lua')
-depends=('libxml2' 'yajl' 'qt5-base' 'python' 'curl' 'boost' 'dbus' 'swig')
+license=('custom:BSD')
+arch=('i686' 'x86_64')
+depends=('yajl' 'qt5-base' 'python' 'curl' 'boost' 'swig')
+optdepends=('ruby: for ruby bindings'
+ 'python2: for python2-bindings'
+ 'xerces-c: for python2-bindings'
+ 'lua: for lua bindings'
+ 'libgit2: for git support')
makedepends=('docbook-xsl' 'cmake' 'doxygen')
source=(https://github.com/ElektraInitiative/libelektra/archive/$pkgver.tar.gz)
-sha256sums=('4a0c226efebb51f6639ab30a49c4eacfb0a9ba7d9c8c7449a788fe8a42222c3f')
+sha256sums=('f9322cffa2f57f15805c97fd1b11277212cefc73058c6ca579fa79ab0e76aabf')
build() {
- cd ${srcdir}/lib$pkgname-$pkgver
+ cd lib$pkgname-$pkgver
rm -rf build
mkdir build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DPLUGINS="ALL" \
- -DTOOLS="ALL" \
- -DBUILD_STATIC=OFF \
- -DBINDINGS="ALL" \
- -DSWIG_EXECUTABLE="/usr/bin/swig" \
- -DLUA_PROGRAM_PATH=/usr/bin/lua \
- -DLUA_INCLUDE_DIR=/usr/include \
- -DLUA_LIBRARY=/usr/lib/liblua.so ..
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DPLUGINS:STRING="ALL" \
+ -DTOOLS:STRING="ALL" \
+ -DBUILD_STATIC:STRING=OFF \
+ -DBINDINGS:STRING="ALL" \
+ -DSWIG_EXECUTABLE:STRING="/usr/bin/swig" \
+ -DLUA_INCLUDE_DIR:PATH=/usr/include \
+ -DLUA_LIBRARY:STRING=/usr/lib/liblua.so ..
make clean
make
}
package() {
- cd ${srcdir}/lib$pkgname-$pkgver/build
- make DESTDIR=${pkgdir} install
+ cd lib$pkgname-$pkgver/build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../LICENSE.md "$pkgdir"/usr/share/licenses/LICENSE.md
}