summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-07-05 16:14:27 +0200
committerhaawda2020-07-05 16:14:27 +0200
commitbde3a53c5811015100ef689528133aba244adfec (patch)
treea0711a8f4f001d2719e516f3fe09d886adafd073
parenta9ab0c15e031d033c745c46c4572f044963bbf04 (diff)
downloadaur-bde3a53c5811015100ef689528133aba244adfec.tar.gz
fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52c02386345a..fd71ec6796f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = elektra
pkgdesc = A universal hierarchical configuration store
pkgver = 0.9.2
- pkgrel = 2
+ pkgrel = 3
url = https://www.libelektra.org
arch = i686
arch = x86_64
@@ -20,7 +20,9 @@ pkgbase = elektra
depends = libgit2
depends = libev
depends = zeromq
+ depends = discount
depends = qt5-quickcontrols
+ depends = hicolor-icon-theme
optdepends = ruby: for ruby bindings
optdepends = python2: for python2-bindings
optdepends = xerces-c: for python2-bindings
diff --git a/PKGBUILD b/PKGBUILD
index aaebe34f8fc1..466a99655542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=elektra
pkgver=0.9.2
-pkgrel=2
+pkgrel=3
pkgdesc="A universal hierarchical configuration store"
url="https://www.libelektra.org"
license=('custom:BSD')
arch=('i686' 'x86_64')
-depends=('yajl' 'qt5-base' 'python' 'curl' 'boost' 'swig' 'libuv' 'libgit2' 'libev' 'zeromq' 'qt5-quickcontrols')
+depends=('yajl' 'qt5-base' 'python' 'curl' 'boost' 'swig' 'libuv' 'libgit2' 'libev' 'zeromq' 'discount' 'qt5-quickcontrols' 'hicolor-icon-theme')
optdepends=('ruby: for ruby bindings'
'python2: for python2-bindings'
'xerces-c: for python2-bindings'
@@ -22,13 +22,16 @@ build() {
[[ -d build ]] || mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_RPATH:PATH=/usr/lib \
-DPLUGINS:STRING="ALL" \
-DTOOLS:STRING="ALL" \
-DBUILD_STATIC:STRING=OFF \
-DBINDINGS:STRING="ALL" \
-DSWIG_EXECUTABLE:STRING="/usr/bin/swig" \
-DLUA_INCLUDE_DIR:PATH=/usr/include \
- -DLUA_LIBRARY:STRING=/usr/lib/liblua.so ..
+ -DLUA_LIBRARY:STRING=/usr/lib/liblua.so \
+ -DTARGET_PLUGIN_FOLDER="" \
+ ..
make clean
make
}