summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody Wyatt Neiman2022-05-21 15:54:15 +0000
committerCody Wyatt Neiman2022-05-21 15:54:15 +0000
commit25427712556e9cdfd433c6e98cc2016f4c52c2ee (patch)
tree72ee54a41e4e5f062370922fe11372635e24fd00
parenta4b9243f9dd50ed481e757e843575fe22b68ad39 (diff)
parent75b7c61b327b4f83a78b41bfa8e92bf74e3f87b0 (diff)
downloadaur-25427712556e9cdfd433c6e98cc2016f4c52c2ee.tar.gz
Merge branch 'gitlab-ci' into 'master'
feat(ci): init test and build stages See merge request xangelix-pub/arch/element-desktop-git!1
-rw-r--r--.gitlab-ci.yml23
1 files changed, 23 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..11de36f88b08
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,23 @@
+stages:
+ - test
+ - build
+
+pamac_test:
+ stage: test
+ image: docker.io/archlinux:latest
+ before_script:
+ - pacman -Sy --noconfirm namcap
+ script:
+ - namcap PKGBUILD
+
+makepkg_build:
+ stage: build
+ image: docker.io/archlinux:latest
+ before_script:
+ - pacman -Sy --noconfirm sudo base-devel
+ - useradd builduser -m && passwd -d builduser && printf 'builduser ALL=(ALL) ALL\n' | tee -a /etc/sudoers
+ script:
+ - sudo -u builduser bash -c 'makepkg -si --noconfirm'
+ artifacts:
+ paths:
+ - "*.zst"