summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGermán2018-10-28 23:35:25 +0100
committerGermán2018-10-28 23:35:25 +0100
commit44bfe7891bec6a46965788b8a9e60720d1cd4f85 (patch)
tree9e6059aea133a3faf72ad34084957fe8c11c15af
downloadaur-44bfe7891bec6a46965788b8a9e60720d1cd4f85.tar.gz
elementary-blue-icon-theme-git: Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49a9d64ebba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = elementary-blue-icon-theme-git
+ pkgdesc = Classic blue folders of the elementary icon theme.
+ pkgver = r2260.5ec8e85d
+ pkgrel = 1
+ url = https://github.com/germanfr/elementary-blue-icons
+ arch = any
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = elementary-icon-theme
+ options = !emptydirs
+ source = elementary-blue-icon-theme::git+https://github.com/germanfr/elementary-blue-icons.git
+ sha256sums = SKIP
+
+pkgname = elementary-blue-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d770939c5279
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Germán Franco <dev.germanfr@gmail.com>
+
+pkgname=elementary-blue-icon-theme-git
+pkgver=r2260.5ec8e85d
+pkgrel=1
+pkgdesc='Classic blue folders of the elementary icon theme.'
+arch=('any')
+url='https://github.com/germanfr/elementary-blue-icons'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('elementary-icon-theme')
+makedepends=('git' 'meson')
+options=('!emptydirs')
+source=('elementary-blue-icon-theme::git+https://github.com/germanfr/elementary-blue-icons.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd elementary-blue-icon-theme
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd build
+
+ arch-meson ../elementary-blue-icon-theme
+ ninja
+}
+
+package() {
+ cd build
+
+ DESTDIR="${pkgdir}" ninja install
+}
+
+# vim: ts=2 sw=2 et:
+