summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-08-09 18:36:46 +0200
committerPhilip Goto2018-08-09 18:36:46 +0200
commitd375dd63f79c7c91d456937afa9d34af2378984d (patch)
tree0cc22f87169a0f15941958395d08b4e445aeee3a
downloadaur-d375dd63f79c7c91d456937afa9d34af2378984d.tar.gz
Initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c47b67e63a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = elementary-code-git
+ pkgdesc = Code editor designed for elementary OS
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/elementary/code
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = editorconfig-core-c
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ provides = elementary-code
+ conflicts = elementary-code
+ source = git+https://github.com/elementary/code.git
+ md5sums = SKIP
+
+pkgname = elementary-code-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1728601d4971
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+_pkgname=elementary-code
+pkgname=$_pkgname-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Code editor designed for elementary OS"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/elementary/code"
+license=('GPL3')
+depends=('gtk3')
+makedepends=('editorconfig-core-c'
+ 'meson'
+ 'vala')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/elementary/code.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd code
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ rm -rf build
+ arch-meson code build
+ ninja -v -C build
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
+}