summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 17:51:14 +0200
committerMaxime Gauduin2017-05-01 17:51:14 +0200
commit205a8dc5a0c74f668293c253ff8d0514aa3242e8 (patch)
treeaa58615508f535037fa2354956924e33377d95b5
downloadaur-205a8dc5a0c74f668293c253ff8d0514aa3242e8.tar.gz
Add elementary-icon-theme-git
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--elementary-icon-theme.install13
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0d57af94784
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon May 1 15:51:14 UTC 2017
+pkgbase = elementary-icon-theme-git
+ pkgdesc = Named, vector icons for elementary OS
+ pkgver = r1968.c27c0112
+ pkgrel = 1
+ url = https://github.com/elementary/icons
+ install = elementary-icon-theme.install
+ arch = any
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = git
+ depends = gtk-update-icon-cache
+ depends = hicolor-icon-theme
+ provides = elementary-icon-theme
+ conflicts = elementary-icon-theme
+ options = !emptydirs
+ source = elementary-icon-theme::git+https://github.com/elementary/icons.git
+ sha256sums = SKIP
+
+pkgname = elementary-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d5befac20d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=elementary-icon-theme-git
+pkgver=r1968.c27c0112
+pkgrel=1
+pkgdesc='Named, vector icons for elementary OS'
+arch=('any')
+url='https://github.com/elementary/icons'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('gtk-update-icon-cache' 'hicolor-icon-theme')
+makedepends=('git')
+provides=('elementary-icon-theme')
+conflicts=('elementary-icon-theme')
+options=('!emptydirs')
+install='elementary-icon-theme.install'
+source=('elementary-icon-theme::git+https://github.com/elementary/icons.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd elementary-icon-theme
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ rm -rf elementary-icon-theme/{.git*,AUTHORS,CONTRIBUTORS,COPYING,README.md,icons/elementary/icon-theme.cache}
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve='ownership' elementary-icon-theme "${pkgdir}"/usr/share/icons/elementary
+}
+
+# vim: ts=2 sw=2 et:
+
diff --git a/elementary-icon-theme.install b/elementary-icon-theme.install
new file mode 100644
index 000000000000..06e322d5ae38
--- /dev/null
+++ b/elementary-icon-theme.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -ftq /usr/share/icons/elementary
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: