summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Glen2015-10-14 13:22:11 -0400
committerIan Glen2015-10-14 13:22:11 -0400
commit4b79df0a8cda97d8e4a79e3a6b2998a92e467b41 (patch)
treecba767c08dd5751515f89d8285f0af60a1ab9dee
downloadaur-4b79df0a8cda97d8e4a79e3a6b2998a92e467b41.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--elementary-plus-icon-theme-git.install14
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..189007b97cdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = elementary-plus-icon-theme-git
+ pkgdesc = An addition to elementary OS's icon theme.
+ pkgver = 548.1100f81
+ pkgrel = 1
+ url = https://github.com/mank319/elementaryPlus
+ install = elementary-plus-icon-theme-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = elementary-icon-theme
+ provides = elementary-plus-icon-theme-git
+ conflicts = elementary-plus-icon-theme-git
+ source = git+https://github.com/mank319/elementaryPlus.git
+ md5sums = SKIP
+
+pkgname = elementary-plus-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5046197f0ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ian Glen <ian@ianglen.me>
+
+pkgname=elementary-plus-icon-theme-git
+_pkgname=elementaryPlus
+pkgver=548.1100f81
+pkgrel=1
+pkgdesc="An addition to elementary OS's icon theme."
+arch=('any')
+url='https://github.com/mank319/elementaryPlus'
+license=('GPL3')
+depends=('elementary-icon-theme')
+optdepends=()
+makedepends=('git')
+provides=("${pkgname%}")
+conflicts=("${pkgname%}")
+install="${pkgname}.install"
+source=('git+https://github.com/mank319/elementaryPlus.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ # create theme dirs
+ install -d -m 755 "$pkgdir"/usr/share/icons/elementary-plus
+
+ # install theme
+ cd $srcdir/$_pkgname/elementaryPlus
+ cp -r . "$pkgdir"/usr/share/icons/elementary-plus/
+}
diff --git a/elementary-plus-icon-theme-git.install b/elementary-plus-icon-theme-git.install
new file mode 100644
index 000000000000..7ac7e6cd86f4
--- /dev/null
+++ b/elementary-plus-icon-theme-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+} \ No newline at end of file