summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Scholer2018-08-28 23:18:30 +0200
committerRaphael Scholer2018-08-28 23:59:35 +0200
commit9722e40dac06f5c649b68856b018d0e71d06cd41 (patch)
tree746b637e5bd358179b1ddf3ac37a7f852f139ad3
parent22c2c2080aae630102afbf6d556eaae91dc9cfc8 (diff)
downloadaur-9722e40dac06f5c649b68856b018d0e71d06cd41.tar.gz
Support new Makefile method
Also re-enable 'strip' makepkg option, since the time penality has decreased to basically nothing.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD37
2 files changed, 32 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d88ed9bf16fb..2a69a83fc289 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-# Generated by mksrcinfo v8
-# Sat Mar 10 23:05:56 UTC 2018
pkgbase = elementary-xfce-icons-git
pkgdesc = Elementary icon-theme with improved Xfce support
- pkgver = 0.10.r2.g9ff56ee0
- pkgrel = 2
+ pkgver = 0.12.r20.g149753da
+ pkgrel = 1
url = https://github.com/shimmerproject/elementary-xfce
arch = any
license = GPL2
makedepends = git
+ makedepends = gtk3
+ makedepends = optipng
depends = adwaita-icon-theme
provides = elementary-xfce-icons
conflicts = elementary-xfce-icons
- options = !strip
source = git+https://github.com/shimmerproject/elementary-xfce
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bf53be268a3b..71142ce5fb89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Raphael Scholer <rascholer@gmail.com>
_pkgname='elementary-xfce'
pkgname="${_pkgname}-icons-git"
-pkgver=0.10.r2.g9ff56ee0
-pkgrel=2
+pkgver=0.12.r20.g149753da
+pkgrel=1
pkgdesc='Elementary icon-theme with improved Xfce support'
arch=('any')
url="https://github.com/shimmerproject/${_pkgname}"
license=('GPL2')
-makedepends=('git')
+makedepends=('git' 'gtk3' 'optipng')
depends=('adwaita-icon-theme')
conflicts=("${_pkgname}-icons")
provides=("${_pkgname}-icons")
-options=(!strip)
source=("git+${url}")
sha256sums=('SKIP')
@@ -20,14 +19,34 @@ pkgver() {
git describe --long --tags | sed "s/^${_pkgname}.//;s/\([^-]*-g\)/r\1/;s/-/./g"
}
-package() {
- install -m 755 -d "${pkgdir}/usr/share/icons"
+prepare() {
+ cd "${_pkgname}"
+
+ # Only run make's build target once.
+ sed -e 's/install: build/install:/' -i Makefile.in
+ # Generation of caches is done by an ALPM hook.
+ sed -e '/@echo .*The icon-theme cache/d' -i Makefile.in
+}
+
+build() {
cd "${_pkgname}"
- cp -r ${_pkgname}{,-dark{,er,est}} "${pkgdir}/usr/share/icons/"
+
+ ./configure --prefix="/usr/"
+ make -j1
+}
+
+package() {
+ cd "${_pkgname}"
+
+ make DESTDIR="${pkgdir}" install
# Remove unneeded files
- cd "${pkgdir}/usr/share/icons"
- rm ${_pkgname}{,-dark{,er,est}}/{AUTHORS,CONTRIBUTORS,LICENSE}
+ find "${pkgdir}/usr/share/icons" \
+ \( \
+ -name 'AUTHORS' \
+ -o -name 'CONTRIBUTORS' \
+ -o -name 'LICENSE' \
+ \) -delete
}
# vim:set ts=2 sw=2 et: