summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregoire Lodi2018-04-08 03:52:04 +0200
committerGregoire Lodi2018-04-08 03:52:04 +0200
commitc7fe1f3c6526456d07b3d9c62267916c8147ed63 (patch)
treefcd6f802c94183fca42f4673e7bd99975313bdde
downloadaur-c7fe1f3c6526456d07b3d9c62267916c8147ed63.tar.gz
elf-strings v0.9.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ffc6f67cb1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = elf-strings
+ pkgdesc = elf-strings will programmatically read an ELF binary's string sections within a given binary. This is meant to be much like the strings UNIX utility, however is purpose built for ELF binaries.
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/LloydLabs/elf-strings
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ source = elf-strings::git+https://github.com/LloydLabs/elf-strings.git
+ md5sums = SKIP
+
+pkgname = elf-strings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25b585549313
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gregoire Lodi <gregoire.lodi@gmail.com>
+
+pkgname=elf-strings
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="elf-strings will programmatically read an ELF binary's string sections within a given binary. This is meant to be much like the strings UNIX utility, however is purpose built for ELF binaries."
+arch=("x86_64")
+url="https://github.com/LloydLabs/elf-strings"
+license=("GPL")
+groups=()
+depends=()
+makedepends=("go")
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname"::"git+${url}.git")
+noextract=()
+md5sums=("SKIP") #autofill using updpkgsums
+
+build() {
+ cd "$pkgname"
+
+ GOPATH="$PWD" GOBIN="$PWD" go get
+ GOPATH="$PWD" GOBIN="$PWD" go build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ echo "installing ${pkgname} to ${pkgdir}"
+ install -Dm 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}