summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2023-01-23 10:19:35 +0100
committerAlexander F. Rødseth2023-01-23 10:19:35 +0100
commit639dfe56d0532d57aa4ec45f4001cc279a4855f6 (patch)
treef1c67610ab015f3c38f9c52b336de44baf11543a
parente45326f329286b3f1e209c40a4804dad05d8cef4 (diff)
downloadaur-elfinfo.tar.gz
New release
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 127d16b01a2b..f2b08c58aa9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = elfinfo
pkgdesc = Detect which compiler version was used for compiling an ELF file
- pkgver = 1.2.1
+ pkgver = 1.2.2
pkgrel = 1
url = https://elfinfo.roboticoverlords.org/
arch = x86_64
license = BSD
makedepends = go
makedepends = git
- source = git+https://github.com/xyproto/elfinfo#commit=0f5a6d671c6d298e7f06d2917a2007e9a547d2ad
+ source = git+https://github.com/xyproto/elfinfo#commit=c222ef706cd6216e5f3d2aca297f2369895beed7
b2sums = SKIP
pkgname = elfinfo
diff --git a/PKGBUILD b/PKGBUILD
index 5c5a6b1d4f87..a8e187b608dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=elfinfo
-pkgver=1.2.1
+pkgver=1.2.2
pkgrel=1
pkgdesc='Detect which compiler version was used for compiling an ELF file'
arch=(x86_64)
url='https://elfinfo.roboticoverlords.org/'
license=(BSD)
makedepends=(go git)
-source=("git+https://github.com/xyproto/elfinfo#commit=0f5a6d671c6d298e7f06d2917a2007e9a547d2ad") # tag: 1.2.1
+source=("git+https://github.com/xyproto/elfinfo#commit=c222ef706cd6216e5f3d2aca297f2369895beed7") # tag: 1.2.2
b2sums=('SKIP')
build() {
cd $pkgname
- go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags $LDFLAGS"
+ go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags '${LDFLAGS}'"
}
package() {
- install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd $pkgname
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}