summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-07-19 14:26:16 +0200
committerAlexander F Rødseth2017-07-19 14:26:16 +0200
commit2b2c379437ff6c41f633f46c7d1984b06f22e389 (patch)
tree60592bb965bd12bb35bec00bc2ceed98085c2185
parenta3a43cb3e38ddb05223629fd0b0ac3aa938f139c (diff)
downloadaur-2b2c379437ff6c41f633f46c7d1984b06f22e389.tar.gz
New release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0b2b4b50dfc..c369a1e03f99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Jun 5 09:56:34 UTC 2017
+# Wed Jul 19 12:26:10 UTC 2017
pkgbase = elfinfo
- pkgdesc = Detect which compiler version was used for compiling an ELF file + basic info
- pkgver = 0.4
+ pkgdesc = Detect which compiler version was used for compiling an ELF file
+ pkgver = 0.5
pkgrel = 1
url = http://elfinfo.roboticoverlords.org/
arch = any
license = MIT
makedepends = go
- source = https://github.com/xyproto/elfinfo/archive/0.4.tar.gz
- sha256sums = 0bceab04e0e73abf15e0d07cca2923779517386cbd6394b1e970d8d950ad646d
+ makedepends = git
+ source = git+https://github.com/xyproto/elfinfo#tag=0.5
+ sha256sums = SKIP
pkgname = elfinfo
diff --git a/PKGBUILD b/PKGBUILD
index 6e10eeff7c0e..a8ef3004907a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,24 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=elfinfo
-pkgver=0.4
+pkgver=0.5
pkgrel=1
-pkgdesc='Detect which compiler version was used for compiling an ELF file + basic info'
+pkgdesc='Detect which compiler version was used for compiling an ELF file'
arch=('any')
url='http://elfinfo.roboticoverlords.org/'
license=('MIT')
-makedepends=('go')
-source=("https://github.com/xyproto/elfinfo/archive/0.4.tar.gz")
-sha256sums=('0bceab04e0e73abf15e0d07cca2923779517386cbd6394b1e970d8d950ad646d')
+makedepends=('go' 'git')
+source=("git+https://github.com/xyproto/elfinfo#tag=$pkgver")
+sha256sums=('SKIP')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
go build
}
package() {
- cd "$pkgname-$pkgver"
-
- install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: