summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-06-05 11:57:20 +0200
committerAlexander F Rødseth2017-06-05 11:57:20 +0200
commita3a43cb3e38ddb05223629fd0b0ac3aa938f139c (patch)
treedc6ca2b7db074ef0babda56158558392f99dee7a
downloadaur-a3a43cb3e38ddb05223629fd0b0ac3aa938f139c.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0b2b4b50dfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Jun 5 09:56:34 UTC 2017
+pkgbase = elfinfo
+ pkgdesc = Detect which compiler version was used for compiling an ELF file + basic info
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://elfinfo.roboticoverlords.org/
+ arch = any
+ license = MIT
+ makedepends = go
+ source = https://github.com/xyproto/elfinfo/archive/0.4.tar.gz
+ sha256sums = 0bceab04e0e73abf15e0d07cca2923779517386cbd6394b1e970d8d950ad646d
+
+pkgname = elfinfo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e10eeff7c0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 194006 2016-10-30 14:58:09Z arodseth $
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=elfinfo
+pkgver=0.4
+pkgrel=1
+pkgdesc='Detect which compiler version was used for compiling an ELF file + basic info'
+arch=('any')
+url='http://elfinfo.roboticoverlords.org/'
+license=('MIT')
+makedepends=('go')
+source=("https://github.com/xyproto/elfinfo/archive/0.4.tar.gz")
+sha256sums=('0bceab04e0e73abf15e0d07cca2923779517386cbd6394b1e970d8d950ad646d')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ go build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: