summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-07-21 13:45:52 +0200
committerAlexander F. Rødseth2022-07-21 13:45:52 +0200
commite45326f329286b3f1e209c40a4804dad05d8cef4 (patch)
tree20ea6dbae2c6762f358e04bc1063ad33dd4465e7
parent4f226377101f010d70e983a945cd939bd050c79b (diff)
downloadaur-e45326f329286b3f1e209c40a4804dad05d8cef4.tar.gz
New release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82cb16b71818..127d16b01a2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = elfinfo
pkgdesc = Detect which compiler version was used for compiling an ELF file
- pkgver = 1.1.0
+ pkgver = 1.2.1
pkgrel = 1
url = https://elfinfo.roboticoverlords.org/
arch = x86_64
- license = MIT
+ license = BSD
makedepends = go
makedepends = git
- source = git+https://github.com/xyproto/elfinfo#commit=fa069dd07e2a1629dcc6fa8bfefd59fc28833fa7
- sha256sums = SKIP
+ source = git+https://github.com/xyproto/elfinfo#commit=0f5a6d671c6d298e7f06d2917a2007e9a547d2ad
+ b2sums = SKIP
pkgname = elfinfo
-
diff --git a/PKGBUILD b/PKGBUILD
index 0b94e335afac..5c5a6b1d4f87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=elfinfo
-pkgver=1.1.0
+pkgver=1.2.1
pkgrel=1
pkgdesc='Detect which compiler version was used for compiling an ELF file'
arch=(x86_64)
url='https://elfinfo.roboticoverlords.org/'
-license=(MIT)
+license=(BSD)
makedepends=(go git)
-source=("git+https://github.com/xyproto/elfinfo#commit=fa069dd07e2a1629dcc6fa8bfefd59fc28833fa7")
-sha256sums=('SKIP')
+source=("git+https://github.com/xyproto/elfinfo#commit=0f5a6d671c6d298e7f06d2917a2007e9a547d2ad") # tag: 1.2.1
+b2sums=('SKIP')
build() {
cd $pkgname
- go build -mod=vendor -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
+ go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags $LDFLAGS"
}
package() {
install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et: