summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo Triggiani2019-12-04 01:06:10 +0100
committerMatteo Triggiani2019-12-04 01:06:10 +0100
commitee7a754fdb8f7eb200f1a01572bdef5715735a1c (patch)
tree4c4ad3ffe3459e0fa6ad9c4e4e4e28c112049f0f
downloadaur-elgato-gchd.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e5998bb2649
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = elgato-gchd
+ pkgdesc = This project provides a userspace driver to natively support the Elgato Game Capture HD under Linux and Mac OS X. This is an unofficial driver and in no way supported by Elgato.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/tolga9009/elgato-gchd
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ source = elgato-gchd::git+https://github.com/tolga9009/elgato-gchd.git
+ md5sums = SKIP
+
+pkgname = elgato-gchd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eee1b1ed704
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Matteo Triggiani <davvore33@gmail.com>
+pkgname=('elgato-gchd')
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="This project provides a userspace driver to natively support the Elgato Game Capture HD under Linux and Mac OS X. This is an unofficial driver and in no way supported by Elgato."
+arch=('x86_64')
+url="https://github.com/tolga9009/elgato-gchd"
+license=('MIT')
+makedepends=('cmake' 'git')
+md5sums=('SKIP')
+
+
+_gitroot='https://github.com/tolga9009'
+_gitname='elgato-gchd'
+source=("$_gitname"::git+"$_gitroot"/"$_gitname".git)
+
+prepare(){
+ cd "${srcdir}/${_gitname}/"
+ git checkout tags/$pkgver
+ mkdir -p build && cd build
+
+ cmake ..
+}
+
+build() {
+
+ cd "${srcdir}/${_gitname}/build"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+