summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2012-02-17 21:04:29 +0530
committerKeshav Amburay2012-02-17 21:04:29 +0530
commit6e186e52a939284891fa6515392b679666116d75 (patch)
treecd7d75f15ab58d38927dd4ff1bd376126229efa5
downloadaur-6e186e52a939284891fa6515392b679666116d75.tar.gz
Initial
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD66
-rw-r--r--elilo-x86_64.install26
-rw-r--r--elilo.conf.example20
5 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9091989e4ad9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = elilo-x86_64
+ pkgdesc = UEFI version of LILO Boot Loader
+ pkgver = 3.14
+ pkgrel = 1
+ url = http://sourceforge.net/projects/elilo/
+ install = elilo-x86_64.install
+ arch = any
+ license = GPL
+ makedepends = gnu-efi
+ depends = dosfstools
+ depends = efibootmgr
+ options = !strip
+ options = purge
+ options = !libtool
+ options = !emptydirs
+ backup = boot/efi/efi/arch_elilo/elilo.conf
+ source = http://downloads.sourceforge.net/project/elilo/elilo/elilo-3.14/elilo-3.14-all.tar.gz
+ source = elilo.conf.example
+ sha1sums = 631fdf211627510b270f0759c26587edb8d30001
+ sha1sums = f38e5194ec100e6c5163a4db570b240e19b37da0
+
+pkgname = elilo-x86_64
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f1307f4c59eb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.xz
+*.tar.gz
+*.log*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..073c235928db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer : Keshav P R <(the.ridikulus.rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
+
+_pkgname="elilo"
+pkgname="${_pkgname}-x86_64"
+
+pkgver="3.14"
+pkgrel="1"
+pkgdesc="UEFI version of LILO Boot Loader"
+arch=('any')
+url="http://sourceforge.net/projects/elilo/"
+license=('GPL')
+
+makedepends=('gnu-efi')
+depends=('dosfstools' 'efibootmgr')
+options=('!strip' 'purge' '!libtool' '!emptydirs')
+
+install="${pkgname}.install"
+backup=("boot/efi/efi/arch_elilo/elilo.conf")
+
+source=("http://downloads.sourceforge.net/project/elilo/elilo/elilo-${pkgver}/elilo-${pkgver}-all.tar.gz"
+ "elilo.conf.example")
+
+sha1sums=('631fdf211627510b270f0759c26587edb8d30001'
+ 'f38e5194ec100e6c5163a4db570b240e19b37da0')
+
+_extract_source() {
+
+ cd "${srcdir}/"
+
+ bsdtar xf "${srcdir}/elilo-${pkgver}-source.tar.gz"
+
+}
+
+build() {
+
+ if [[ "${CARCH}" != "x86_64" ]]; then
+ echo "${pkgname} package can be built only in a x86_64 system. Exiting."
+ exit 1
+ else
+ _extract_source
+ fi
+
+ cd "${srcdir}/elilo/"
+
+ ## Enable ext2 drivers - build fails for now
+ # sed 's|CONFIG_ext2fs=n|CONFIG_ext2fs=y|g' -i "${srcdir}/elilo/Make.defaults" || true
+ sed 's|DEBUGFLAGS = -Wall|DEBUGFLAGS = -Wall -Wno-error|g' -i "${srcdir}/elilo/Make.defaults" || true
+
+ CFLAGS="" make
+ echo
+
+}
+
+
+package() {
+
+ cd "${srcdir}/elilo/"
+
+ install -d "${pkgdir}/boot/efi/efi/arch_elilo/"
+ install -D -m0644 "${srcdir}/elilo/elilo.efi" "${pkgdir}/boot/efi/efi/arch_elilo/elilox64.efi"
+ install -D -m0644 "${srcdir}/elilo.conf.example" "${pkgdir}/boot/efi/efi/arch_elilo/elilo.conf"
+
+ # install -d "${pkgdir}/usr/sbin/"
+ # install -D -m0755 "${srcdir}/elilo/tools/eliloalt" "${pkgdir}/usr/sbin/eliloalt"
+
+}
diff --git a/elilo-x86_64.install b/elilo-x86_64.install
new file mode 100644
index 000000000000..75416e7fd983
--- /dev/null
+++ b/elilo-x86_64.install
@@ -0,0 +1,26 @@
+post_install() {
+
+ cat << EOF
+
+Important instructions :-
+
+ELILO is installed at /boot/efi/efi/arch_elilo/elilox64.efi
+
+An example config file has been provided at /boot/efi/efi/arch_elilo/elilo.conf
+
+Edit this file according to your system and rename it as /boot/efi/efi/arch_elilo/elilo.conf
+Copy your kernel(s) and initramfs files from /boot to /boot/efi
+Reboot and launch elilox64.efi from the UEFI shell or add an entry using efibootmgr
+
+NOTE: elilo supports only FAT12/16/32 . It does not support EXT2, EXT3, EXT4 and other Unix filesystems.
+
+EOF
+
+}
+
+post_upgrade() {
+
+ post_install
+
+}
+
diff --git a/elilo.conf.example b/elilo.conf.example
new file mode 100644
index 000000000000..83659f25a1bb
--- /dev/null
+++ b/elilo.conf.example
@@ -0,0 +1,20 @@
+# chooser=textmenu
+prompt
+
+default=arch
+timeout=10
+# lba32
+
+image=/vmlinuz-linux
+ label=arch
+ append="rootfstype=ext4 gpt add_efi_memmap"
+ root=/dev/disk/by-uuid/XXXXXXXXXXXXXXXXXXXXXXXXXXXX
+ initrd=/initramfs-linux.img
+ read-only
+
+image=/vmlinuz-linux
+ label=arch-fallback
+ append="rootfstype=ext4 gpt add_efi_memmap"
+ root=/dev/disk/by-uuid/XXXXXXXXXXXXXXXXXXXXXXXXXXXX
+ initrd=/initramfs-linux-fallback.img
+ read-only