summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-06-21 22:03:13 +0530
committerKeshav Amburay2013-06-21 22:03:13 +0530
commit9bfbbae46ceb80e57a4f128507c798708500dd43 (patch)
tree11d289ec57dfeeaed8ed0897f85952656582bcd1
parent4636a35440becc9931cc8f9b880959ddd672283c (diff)
downloadaur-9bfbbae46ceb80e57a4f128507c798708500dd43.tar.gz
Do not support cross-ARCH build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD62
-rw-r--r--elilo-efi.install2
-rw-r--r--elilo.conf1
4 files changed, 21 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da1bc4a458ec..ba605aba22d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = elilo-efi
pkgdesc = UEFI version of LILO Boot Loader
pkgver = 3.16
- pkgrel = 2
+ pkgrel = 3
url = http://sourceforge.net/projects/elilo/
install = elilo-efi.install
- arch = any
+ arch = x86_64
+ arch = i686
license = GPL
makedepends = gnu-efi-libs
depends = dosfstools
@@ -17,7 +18,7 @@ pkgbase = elilo-efi
source = http://downloads.sourceforge.net/project/elilo/elilo/elilo-3.16/elilo-3.16-all.tar.gz
source = elilo.conf
sha1sums = bd0bd4f1b3dc2d23a304f957ffbf907ae104f323
- sha1sums = 2366629b137572f91774a0bdf907864dd7fe3172
+ sha1sums = b4c2eb097f733f0169d930af12ad590e47adf4b7
pkgname = elilo-efi
diff --git a/PKGBUILD b/PKGBUILD
index 6168f02ca888..7af4ea1a3f4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@ _pkgname="elilo"
pkgname="${_pkgname}-efi"
pkgver="3.16"
-pkgrel="2"
+pkgrel="3"
pkgdesc="UEFI version of LILO Boot Loader"
-arch=('any')
+arch=('x86_64' 'i686')
url="http://sourceforge.net/projects/elilo/"
license=('GPL')
@@ -20,43 +20,7 @@ source=("http://downloads.sourceforge.net/project/elilo/elilo/elilo-${pkgver}/el
"elilo.conf")
sha1sums=('bd0bd4f1b3dc2d23a304f957ffbf907ae104f323'
- '2366629b137572f91774a0bdf907864dd7fe3172')
-
-_build_elilo-efi-x86_64() {
-
- cp -r "${srcdir}/elilo-${pkgver}-source" "${srcdir}/elilo-${pkgver}-x86_64"
- cd "${srcdir}/elilo-${pkgver}-x86_64/"
-
- ## Unset all compiler FLAGS
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
- echo
- make ARCH="x86_64"
- echo
-
-}
-
-_build_elilo-efi-ia32() {
-
- cp -r "${srcdir}/elilo-${pkgver}-source" "${srcdir}/elilo-${pkgver}-ia32"
- cd "${srcdir}/elilo-${pkgver}-ia32/"
-
- ## Unset all compiler FLAGS
- unset CFLAGS
- unset CPPFLAGS
- unset CXXFLAGS
- unset LDFLAGS
- unset MAKEFLAGS
-
- echo
- make ARCH="ia32"
- echo
-
-}
+ 'b4c2eb097f733f0169d930af12ad590e47adf4b7')
build() {
@@ -66,6 +30,7 @@ build() {
fi
bsdtar -C "${srcdir}/" -xf "${srcdir}/elilo-${pkgver}-source.tar.gz"
+ echo
cd "${srcdir}/elilo-${pkgver}-source/"
@@ -82,21 +47,26 @@ build() {
## Fix -Werror build failure
sed 's|DEBUGFLAGS = -Wall|DEBUGFLAGS = -Wall -Wno-error|g' -i "${srcdir}/elilo-${pkgver}-source/Make.defaults" || true
- ## Compile elilox64.efi
- _build_elilo-efi-x86_64
+ cd "${srcdir}/elilo-${pkgver}-source/"
- ## Compile eliloia32.efi
- _build_elilo-efi-ia32
+ ## Unset all compiler FLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
+
+ make
+ echo
}
package() {
- ## Install elilox64.efi and eliloia32.efi
+ ## Install elilo.efi
install -d "${pkgdir}/usr/lib/elilo"
- install -D -m0644 "${srcdir}/elilo-${pkgver}-x86_64/elilo.efi" "${pkgdir}/usr/lib/elilo/elilox64.efi"
- install -D -m0644 "${srcdir}/elilo-${pkgver}-ia32/elilo.efi" "${pkgdir}/usr/lib/elilo/eliloia32.efi"
+ install -D -m0644 "${srcdir}/elilo-${pkgver}-source/elilo.efi" "${pkgdir}/usr/lib/elilo/elilo.efi"
## Install example elilo.conf
install -d "${pkgdir}/usr/lib/elilo/config"
diff --git a/elilo-efi.install b/elilo-efi.install
index f23832e6a6e9..3be1c99de8ed 100644
--- a/elilo-efi.install
+++ b/elilo-efi.install
@@ -4,7 +4,7 @@ post_install() {
Important instructions :-
-ELILO is installed at /usr/lib/elilo/*.efi
+ELILO is installed at /usr/lib/elilo/elilo.efi
An example config file has been provided at /usr/lib/elilo/config/elilo.conf
diff --git a/elilo.conf b/elilo.conf
index 56f15344d429..12a50a31dfe9 100644
--- a/elilo.conf
+++ b/elilo.conf
@@ -1,4 +1,3 @@
-# chooser=textmenu
prompt
default=arch