summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2012-04-29 12:21:24 +0530
committerKeshav Amburay2012-04-29 12:21:24 +0530
commitdeeea8670d147f16ad3e2d6c75bf6287636619da (patch)
treed9bcbf80759486531e5de3cfa9a1562791c3f3ac
parent07ab5ca2a97e596761773adf56fa8357d4e7bd7b (diff)
downloadaur-deeea8670d147f16ad3e2d6c75bf6287636619da.tar.gz
B
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--elilo-x86_64.install6
-rw-r--r--elilo.conf.example8
4 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05d329032899..2fa32727c260 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,11 +13,11 @@ pkgbase = elilo-x86_64
options = purge
options = !libtool
options = !emptydirs
- backup = boot/efi/efi/arch/elilo/elilo.conf
+ backup = boot/efi/EFI/arch/elilo/elilo.conf
source = http://downloads.sourceforge.net/project/elilo/elilo/elilo-3.14/elilo-3.14-all.tar.gz
source = elilo.conf.example
sha1sums = 631fdf211627510b270f0759c26587edb8d30001
- sha1sums = f38e5194ec100e6c5163a4db570b240e19b37da0
+ sha1sums = 37cf9c4c94a4571863864fe60804f04d24ed1a1e
pkgname = elilo-x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8899eaaa36a0..892e191a7c18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,13 +15,13 @@ depends=('dosfstools' 'efibootmgr')
options=('!strip' 'purge' '!libtool' '!emptydirs')
install="${pkgname}.install"
-backup=("boot/efi/efi/arch/elilo/elilo.conf")
+backup=("boot/efi/EFI/arch/elilo/elilo.conf")
source=("http://downloads.sourceforge.net/project/elilo/elilo/elilo-${pkgver}/elilo-${pkgver}-all.tar.gz"
"elilo.conf.example")
sha1sums=('631fdf211627510b270f0759c26587edb8d30001'
- 'f38e5194ec100e6c5163a4db570b240e19b37da0')
+ '37cf9c4c94a4571863864fe60804f04d24ed1a1e')
_extract_source() {
@@ -42,6 +42,9 @@ build() {
cd "${srcdir}/elilo/"
+ make clean || true
+ echo
+
## Enable ext2 drivers - build fails for now
# sed 's|CONFIG_ext2fs=n|CONFIG_ext2fs=y|g' -i "${srcdir}/elilo/Make.defaults" || true
sed 's|DEBUGFLAGS = -Wall|DEBUGFLAGS = -Wall -Wno-error|g' -i "${srcdir}/elilo/Make.defaults" || true
@@ -56,9 +59,9 @@ package() {
cd "${srcdir}/elilo/"
- install -d "${pkgdir}/boot/efi/efi/arch/elilo/"
- install -D -m0644 "${srcdir}/elilo/elilo.efi" "${pkgdir}/boot/efi/efi/arch/elilo/elilox64.efi"
- install -D -m0644 "${srcdir}/elilo.conf.example" "${pkgdir}/boot/efi/efi/arch/elilo/elilo.conf"
+ install -d "${pkgdir}/boot/efi/EFI/arch/elilo/"
+ install -D -m0644 "${srcdir}/elilo/elilo.efi" "${pkgdir}/boot/efi/EFI/arch/elilo/elilox64.efi"
+ install -D -m0644 "${srcdir}/elilo.conf.example" "${pkgdir}/boot/efi/EFI/arch/elilo/elilo.conf"
# install -d "${pkgdir}/usr/sbin/"
# install -D -m0755 "${srcdir}/elilo/tools/eliloalt" "${pkgdir}/usr/sbin/eliloalt"
diff --git a/elilo-x86_64.install b/elilo-x86_64.install
index 773241542dbe..e22486a366ba 100644
--- a/elilo-x86_64.install
+++ b/elilo-x86_64.install
@@ -4,11 +4,11 @@ post_install() {
Important instructions :-
-ELILO is installed at /boot/efi/efi/arch/elilo/elilox64.efi
+ELILO is installed at /boot/efi/EFI/arch/elilo/elilox64.efi
-An example config file has been provided at /boot/efi/efi/arch/elilo/elilo.conf
+An example config file has been provided at /boot/efi/EFI/arch/elilo/elilo.conf
-Edit this file according to your system and rename it as /boot/efi/efi/arch/elilo/elilo.conf
+Edit this file according to your system and rename it as /boot/efi/EFI/arch/elilo/elilo.conf
Copy your kernel(s) and initramfs files from /boot to /boot/efi
Reboot and launch elilox64.efi from the UEFI shell or add an entry using efibootmgr
diff --git a/elilo.conf.example b/elilo.conf.example
index 83659f25a1bb..bfe57927dd82 100644
--- a/elilo.conf.example
+++ b/elilo.conf.example
@@ -5,16 +5,16 @@ default=arch
timeout=10
# lba32
-image=/vmlinuz-linux
+image=/EFI/arch/vmlinuz-linux.efi
label=arch
append="rootfstype=ext4 gpt add_efi_memmap"
root=/dev/disk/by-uuid/XXXXXXXXXXXXXXXXXXXXXXXXXXXX
- initrd=/initramfs-linux.img
+ initrd=/EFI/arch/initramfs-linux.img
read-only
-image=/vmlinuz-linux
+image=/EFI/arch/vmlinuz-linux.efi
label=arch-fallback
append="rootfstype=ext4 gpt add_efi_memmap"
root=/dev/disk/by-uuid/XXXXXXXXXXXXXXXXXXXXXXXXXXXX
- initrd=/initramfs-linux-fallback.img
+ initrd=/EFI/arch/initramfs-linux-fallback.img
read-only