summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-05-03 17:18:20 +0530
committerKeshav Amburay2013-05-03 17:18:20 +0530
commitea3e1ff297a7efdec55dd7f9826d90fde4c3c621 (patch)
tree57696a30e4299728e7629e73be3008dce1c38898
parent19ff1f4508beccb29be81fef0c5540c834bb38e0 (diff)
downloadaur-ea3e1ff297a7efdec55dd7f9826d90fde4c3c621.tar.gz
Update for v3.16
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD74
-rw-r--r--elilo-efi-x86_64.install26
-rw-r--r--elilo-efi.install22
-rw-r--r--elilo.conf.example17
6 files changed, 83 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52ffedf773bd..be56e6665d91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-pkgbase = elilo-efi-x86_64
- pkgdesc = x86_64 UEFI version of LILO Boot Loader
- pkgver = 3.14
+pkgbase = elilo-efi
+ pkgdesc = UEFI version of LILO Boot Loader
+ pkgver = 3.16
pkgrel = 1
url = http://sourceforge.net/projects/elilo/
- install = elilo-efi-x86_64.install
+ install = elilo-efi.install
arch = any
license = GPL
makedepends = gnu-efi
@@ -13,11 +13,11 @@ pkgbase = elilo-efi-x86_64
options = purge
options = !libtool
options = !emptydirs
- backup = boot/efi/EFI/arch/elilo/elilo.conf
- source = http://downloads.sourceforge.net/project/elilo/elilo/elilo-3.14/elilo-3.14-all.tar.gz
+ options = !makeflags
+ source = http://downloads.sourceforge.net/project/elilo/elilo/elilo-3.16/elilo-3.16-all.tar.gz
source = elilo.conf.example
- sha1sums = 631fdf211627510b270f0759c26587edb8d30001
- sha1sums = 37cf9c4c94a4571863864fe60804f04d24ed1a1e
+ sha1sums = bd0bd4f1b3dc2d23a304f957ffbf907ae104f323
+ sha1sums = b961f6181504f7d1bf4b14f76c0477159fc54445
-pkgname = elilo-efi-x86_64
+pkgname = elilo-efi
diff --git a/.gitignore b/.gitignore
index f1307f4c59eb..3ccde5a9a794 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ pkg/
*.tar.xz
*.tar.gz
*.log*
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index 223c7b54a538..38ce7359960e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,26 @@
# Maintainer : Keshav P R <(the.ridikulus.rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
_pkgname="elilo"
-pkgname="${_pkgname}-efi-x86_64"
+pkgname="${_pkgname}-efi"
-pkgver="3.14"
+pkgver="3.16"
pkgrel="1"
-pkgdesc="x86_64 UEFI version of LILO Boot Loader"
+pkgdesc="UEFI version of LILO Boot Loader"
arch=('any')
url="http://sourceforge.net/projects/elilo/"
license=('GPL')
makedepends=('gnu-efi')
depends=('dosfstools' 'efibootmgr')
-options=('!strip' 'purge' '!libtool' '!emptydirs')
+options=('!strip' 'purge' '!libtool' '!emptydirs' '!makeflags')
install="${pkgname}.install"
-backup=("boot/efi/EFI/arch/elilo/elilo.conf")
source=("http://downloads.sourceforge.net/project/elilo/elilo/elilo-${pkgver}/elilo-${pkgver}-all.tar.gz"
"elilo.conf.example")
-sha1sums=('631fdf211627510b270f0759c26587edb8d30001'
- '37cf9c4c94a4571863864fe60804f04d24ed1a1e')
-
-_extract_source() {
-
- cd "${srcdir}/"
-
- bsdtar xf "${srcdir}/elilo-${pkgver}-source.tar.gz"
-
-}
+sha1sums=('bd0bd4f1b3dc2d23a304f957ffbf907ae104f323'
+ 'b961f6181504f7d1bf4b14f76c0477159fc54445')
build() {
@@ -37,19 +28,46 @@ build() {
echo "${pkgname} package can be built only in a x86_64 system. Exiting."
exit 1
else
- _extract_source
+ cd "${srcdir}/"
+ bsdtar xf "${srcdir}/elilo-${pkgver}-source.tar.gz"
fi
- cd "${srcdir}/elilo/"
+ cd "${srcdir}/elilo-${pkgver}-source/"
+ rm -f "${srcdir}"/*.efi || true
+ rm -f "${srcdir}/elilo-${pkgver}-source.tar.gz" || true
- make clean || true
- echo
+ ## Fix ARCH Makefile variable
+ sed 's|ARCH :=|ARCH ?=|g' -i "${srcdir}/elilo-${pkgver}-source/Make.defaults" || true
+ sed 's|dpkg-architecture -qDEB_BUILD_ARCH|uname -m|g' -i "${srcdir}/elilo-${pkgver}-source/Make.defaults" || true
+
+ ## Fix -Werror issues
+ sed 's|DEBUGFLAGS = -Wall|DEBUGFLAGS = -Wall -Wno-error|g' -i "${srcdir}/elilo-${pkgver}-source/Make.defaults" || true
## Enable ext2 drivers - build fails for now
- # sed 's|CONFIG_ext2fs=n|CONFIG_ext2fs=y|g' -i "${srcdir}/elilo/Make.defaults" || true
- sed 's|DEBUGFLAGS = -Wall|DEBUGFLAGS = -Wall -Wno-error|g' -i "${srcdir}/elilo/Make.defaults" || true
+ # sed 's|^CONFIG_ext2fs=n|CONFIG_ext2fs=y|g' -i "${srcdir}/elilo-${pkgver}-source/Make.defaults" || true
- CFLAGS="" make
+ cp -r "${srcdir}/elilo-${pkgver}-source" "${srcdir}/elilo-${pkgver}-x86_64"
+ cd "${srcdir}/elilo-${pkgver}-x86_64/"
+
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
+
+ ARCH="x86_64" make
+ echo
+
+ cp -r "${srcdir}/elilo-${pkgver}-source" "${srcdir}/elilo-${pkgver}-ia32"
+ cd "${srcdir}/elilo-${pkgver}-ia32/"
+
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
+
+ ARCH="ia32" make
echo
}
@@ -57,13 +75,11 @@ build() {
package() {
- cd "${srcdir}/elilo/"
-
- install -d "${pkgdir}/boot/efi/EFI/arch/elilo/"
- install -D -m0644 "${srcdir}/elilo/elilo.efi" "${pkgdir}/boot/efi/EFI/arch/elilo/elilox64.efi"
- install -D -m0644 "${srcdir}/elilo.conf.example" "${pkgdir}/boot/efi/EFI/arch/elilo/elilo.conf"
+ install -d "${pkgdir}/usr/lib/elilo"
+ install -D -m0644 "${srcdir}/elilo-${pkgver}-x86_64/elilo.efi" "${pkgdir}/usr/lib/elilo/elilox64.efi"
+ install -D -m0644 "${srcdir}/elilo-${pkgver}-ia32/elilo.efi" "${pkgdir}/usr/lib/elilo/eliloia32.efi"
- # install -d "${pkgdir}/usr/sbin/"
- # install -D -m0755 "${srcdir}/elilo/tools/eliloalt" "${pkgdir}/usr/sbin/eliloalt"
+ install -d "${pkgdir}/usr/lib/elilo/config"
+ install -D -m0644 "${srcdir}/elilo.conf.example" "${pkgdir}/usr/lib/elilo/config/elilo.conf"
}
diff --git a/elilo-efi-x86_64.install b/elilo-efi-x86_64.install
deleted file mode 100644
index e22486a366ba..000000000000
--- a/elilo-efi-x86_64.install
+++ /dev/null
@@ -1,26 +0,0 @@
-post_install() {
-
- cat << EOF
-
-Important instructions :-
-
-ELILO is installed at /boot/efi/EFI/arch/elilo/elilox64.efi
-
-An example config file has been provided at /boot/efi/EFI/arch/elilo/elilo.conf
-
-Edit this file according to your system and rename it as /boot/efi/EFI/arch/elilo/elilo.conf
-Copy your kernel(s) and initramfs files from /boot to /boot/efi
-Reboot and launch elilox64.efi from the UEFI shell or add an entry using efibootmgr
-
-NOTE: elilo supports only FAT12/16/32 . It does not support EXT2, EXT3, EXT4 and other Unix filesystems.
-
-EOF
-
-}
-
-post_upgrade() {
-
- post_install
-
-}
-
diff --git a/elilo-efi.install b/elilo-efi.install
new file mode 100644
index 000000000000..f23832e6a6e9
--- /dev/null
+++ b/elilo-efi.install
@@ -0,0 +1,22 @@
+post_install() {
+
+ cat << EOF
+
+Important instructions :-
+
+ELILO is installed at /usr/lib/elilo/*.efi
+
+An example config file has been provided at /usr/lib/elilo/config/elilo.conf
+
+NOTE: elilo supports only FAT12/16/32 . It does not support EXT2, EXT3, EXT4 and other Unix filesystems.
+
+EOF
+
+}
+
+post_upgrade() {
+
+ post_install
+
+}
+
diff --git a/elilo.conf.example b/elilo.conf.example
index bfe57927dd82..f70e1f8f4e55 100644
--- a/elilo.conf.example
+++ b/elilo.conf.example
@@ -3,18 +3,13 @@ prompt
default=arch
timeout=10
-# lba32
-image=/EFI/arch/vmlinuz-linux.efi
+image=/EFI/arch/vmlinuz-arch.efi
label=arch
- append="rootfstype=ext4 gpt add_efi_memmap"
- root=/dev/disk/by-uuid/XXXXXXXXXXXXXXXXXXXXXXXXXXXX
- initrd=/EFI/arch/initramfs-linux.img
- read-only
+ append="root=PARTUUID=XXXXXXXXXX rootfstype=ext4 add_efi_memmap"
+ initrd=/EFI/arch/initramfs-arch.img
-image=/EFI/arch/vmlinuz-linux.efi
+image=/EFI/arch/vmlinuz-arch.efi
label=arch-fallback
- append="rootfstype=ext4 gpt add_efi_memmap"
- root=/dev/disk/by-uuid/XXXXXXXXXXXXXXXXXXXXXXXXXXXX
- initrd=/EFI/arch/initramfs-linux-fallback.img
- read-only
+ append="root=PARTUUID=XXXXXXXXXX rootfstype=ext4 add_efi_memmap"
+ initrd=/EFI/arch/initramfs-arch-fallback.img