summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:12:29 +0200
committerStefan Husmann2015-06-09 00:12:29 +0200
commit8c788ffdc0b50abfd426a68e9ebba053fcddfc22 (patch)
treeda3f0e6564bda06e5240eb456424533e43fd3d2d
downloadaur-8c788ffdc0b50abfd426a68e9ebba053fcddfc22.tar.gz
initial version
-rw-r--r--.SRCINFO20
-rw-r--r--COPYING28
-rw-r--r--PKGBUILD23
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5370602f4ee9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = elk
+ pkgdesc = Scheme interpreter and extension language.
+ pkgver = 3.99.8
+ pkgrel = 1
+ url = http://sam.zoy.org/elk/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc
+ depends = openmotif
+ depends = libelf
+ depends = gdbm
+ depends = libxaw
+ source = http://sam.zoy.org/elk/elk-3.99.8.tar.bz2
+ source = COPYING
+ md5sums = 1e68d7370907d575efa706fd9ceb28fd
+ md5sums = 71807aa857f424ba48804e066c3623d3
+
+pkgname = elk
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..c4f769299919
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,28 @@
+$Id: COPYING 220 2003-09-28 12:49:25Z sam $
+
+Copyright 1990, 1991, 1992, 1993, 1994, 1995, Oliver Laumann, Berlin
+(except for the contents of the directory `doc/usenix').
+Copyright 2002, 2003 Sam Hocevar <sam@zoy.org>, Paris
+
+This software was derived from Elk 1.2, which was Copyright 1987, 1988,
+1989, Nixdorf Computer AG and TELES GmbH, Berlin (Elk 1.2 has been written
+by Oliver Laumann (me) for TELES Telematic Services, Berlin, in a joint
+project between TELES and Nixdorf Microprocessor Engineering, Berlin).
+
+Oliver Laumann, TELES GmbH, and Nixdorf Computer AG, as co-owners or
+individual owners of copyright in this software, grant to any person or
+company a worldwide, royalty free, license to
+
+ i) copy this software,
+ ii) prepare derivative works based on this software,
+ iii) distribute copies of this software or derivative works,
+ iv) perform this software, or
+ v) display this software,
+
+provided that this notice is not removed and that neither Oliver Laumann
+nor Teles nor Nixdorf are deemed to have made any representations as to
+the suitability of this software for any purpose nor are held responsible
+for any defects of this software.
+
+THERE IS ABSOLUTELY NO WARRANTY FOR THIS SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7a8a76ab66c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Roberto Alsina <ralsina@kde.org>
+pkgname=elk
+pkgver=3.99.8
+pkgrel=1
+pkgdesc="Scheme interpreter and extension language."
+arch=('i686' 'x86_64')
+url="http://sam.zoy.org/elk/"
+license=('custom')
+depends=('gcc' 'openmotif' 'libelf' 'gdbm' 'libxaw')
+source=(http://sam.zoy.org/elk/elk-$pkgver.tar.bz2 COPYING)
+md5sums=('1e68d7370907d575efa706fd9ceb28fd'
+ '71807aa857f424ba48804e066c3623d3')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+ install -D ../COPYING $pkgdir/usr/share/licenses/elk/COPYING
+}