summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Vospěl2023-01-16 12:36:39 +0100
committerMarek Vospěl2023-01-16 12:39:55 +0100
commit496b0cf9eb580d841a85ced470ebff4d14c4cd44 (patch)
tree272ace887067dec4dab4efdc294a53cacb6194e8
downloadaur-496b0cf9eb580d841a85ced470ebff4d14c4cd44.tar.gz
feat: initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD47
-rw-r--r--elk-zone.desktop9
-rw-r--r--elk-zone.desktop.sigbin0 -> 310 bytes
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c59da2278152
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = elk-zone-git
+ pkgdesc = Native version of Elk, a nimble Mastodon web client.
+ pkgver = v0.5.0.next.1.0.g0d3908a
+ pkgrel = 1
+ url = https://github.com/elk-zone/elk-native
+ arch = any
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = npm
+ source = git+https://github.com/elk-zone/elk-native.git
+ source = elk-zone.desktop
+ source = elk-zone.desktop.sig
+ validpgpkeys = 11967103FD525D8611D25DB2654D7FAA1531BC24
+ sha256sums = SKIP
+ sha256sums = 0bf937c26ee016cf3592c2e574778bf827f9d6d795e03bf068b56f09a38c58fe
+ sha256sums = SKIP
+
+pkgname = elk-zone-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e70e029c574a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+src
+pkg
+# built package
+*.pkg.tar.zst
+# Git remote
+elk-native
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d06a4d700a79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer Marek Vospěl <marek@vospel.cz>
+
+pkgname='elk-zone-git'
+pkgdesc='Native version of Elk, a nimble Mastodon web client.'
+url='https://github.com/elk-zone/elk-native'
+pkgver=v0.5.0.next.1.0.g0d3908a
+pkgrel=1
+arch=('any')
+license=('MIT')
+
+makedepends=('rust' 'cargo' 'npm')
+
+source=('git+https://github.com/elk-zone/elk-native.git'
+ elk-zone.desktop{,.sig})
+sha256sums=('SKIP'
+ '0bf937c26ee016cf3592c2e574778bf827f9d6d795e03bf068b56f09a38c58fe'
+ 'SKIP')
+validpgpkeys=('11967103FD525D8611D25DB2654D7FAA1531BC24')
+
+pkgver() {
+ cd elk-native
+ printf "$(git describe --long --tags | sed -E 's/[\s\/\\-]+/./g')"
+}
+
+build() {
+ cd elk-native
+ git submodule init
+ git submodule update
+
+ cd elk
+ if [ $(which pnpm 2>/dev/null) ]; then
+ pnpm i
+ pnpm run build
+ else
+ npm_config_yes=true npx pnpm i < /dev/null
+ npm run build
+ fi
+
+ cd ..
+ cargo build --release
+}
+
+package() {
+ install -Dm775 elk-native/target/release/app "$pkgdir"/usr/bin/elk-zone
+ install -Dm755 elk-native/logo-dev.png "$pkgdir"/usr/share/icons/elk-zone.png
+ install -Dm755 elk-zone.desktop "$pkgdir"/usr/share/applications/elk-zone.desktop
+}
diff --git a/elk-zone.desktop b/elk-zone.desktop
new file mode 100644
index 000000000000..89cfba434378
--- /dev/null
+++ b/elk-zone.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Elk Zone
+Comment=A nimble Mastodon web client
+Exec=/usr/bin/elk-zone
+Icon=/usr/share/icons/elk-zone.png
+Terminal=false
+Categories=Network;InstantMessaging
+X-Desktop-File-Install-Version=0.26
diff --git a/elk-zone.desktop.sig b/elk-zone.desktop.sig
new file mode 100644
index 000000000000..f01d03103c0f
--- /dev/null
+++ b/elk-zone.desktop.sig
Binary files differ