summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-01-29 21:35:29 -0800
committerDonald Carr2016-01-29 21:36:02 -0800
commit5b1cd60560e838a20646249cf0a2c8699eb9980e (patch)
treebdd95429775b37030f3eb9da06ff9ad34bf0e5d0
downloadaur-5b1cd60560e838a20646249cf0a2c8699eb9980e.tar.gz
Initial commit of the ellcc pkgbuild
Change-Id: Ib532ec596e042f61ee8f39a1c35e382c3d30d0a3
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fb7e8c586d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jan 30 05:35:45 UTC 2016
+pkgbase = ellcc
+ pkgdesc = The ELLCC Embedded Compiler Collection
+ pkgver = 0.1.28
+ pkgrel = 1
+ url = http://ellcc.org/
+ arch = x86_64
+ license = BSD
+ license = MIT
+ license = UIUC
+ provides = ellcc
+ conflicts = ellcc
+ replaces = ellcc
+ options = !strip
+ source = http://ellcc.org/releases/ellcc-x86_64-linux-eng-0.1.28.tgz
+ sha256sums = fbe5f01ada5c52406d1875704031c3503518acec1b215a5cd46ba36ee2125a5e
+
+pkgname = ellcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42dd9970d1e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributer: Donald Carr <sirspudd@gmail.com>
+
+pkgname=ellcc
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=("${pkgname}")
+url="http://ellcc.org/"
+pkgver=0.1.28
+pkgrel=1
+pkgdesc="The ELLCC Embedded Compiler Collection"
+arch=("x86_64")
+license=("BSD" "MIT" "UIUC")
+#depends=()
+#makedepends=()
+_filename="ellcc-x86_64-linux-eng-${pkgver}.tgz"
+source=("http://ellcc.org/releases/${_filename}")
+sha256sums=("fbe5f01ada5c52406d1875704031c3503518acec1b215a5cd46ba36ee2125a5e")
+options=('!strip')
+
+package() {
+ local resting_place="${pkgdir}/opt"
+ mkdir -p ${resting_place}
+ cp -r ${srcdir}/${pkgname} ${resting_place}
+}