summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2023-01-17 19:31:02 +0900
committerShohei Maruyama2023-01-17 19:31:02 +0900
commitd8792d654743eb600587daecb82d17fde5ea8386 (patch)
tree6960c9859536f36ee45cc74d93bac03511e73a25
parent9a377099f106958f421fa1611d258c6e014633aa (diff)
downloadaur-elm-git.tar.gz
PKGBUILD: Change pkgver()
Change pkgver() to use the most recently tag. Signed-off-by: Shohei Maruyama <cheat.sc.linux@outlook.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 265b61eae669..71e958e771d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = elm-git
pkgdesc = Compiler for Elm, a functional language for reliable webapps
pkgver = 0.18.0.r1814.g047d5026
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/elm/compiler
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 1d6d4cbf7a44..0c7cd7db6381 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='elm-git'
pkgver=0.18.0.r1814.g047d5026
-pkgrel=1
+pkgrel=2
pkgdesc='Compiler for Elm, a functional language for reliable webapps'
arch=('x86_64' 'aarch64')
url='https://github.com/elm/compiler'
@@ -32,7 +32,7 @@ sha256sums=('SKIP')
pkgver() {
cd compiler
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {