summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Werling2018-07-11 21:20:51 +0200
committerLukas Werling2018-07-11 21:20:51 +0200
commit773f6157fe917b1d82f3f91ffc31f89c832360eb (patch)
tree4bd677ff1b9ff2912c24b16b5f90935146d8f549
parent8093d40db79cf3ca2817e814bd75ea2c1b55bf5b (diff)
downloadaur-773f6157fe917b1d82f3f91ffc31f89c832360eb.tar.gz
Update with suggestions from AUR comments
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02d7a1764d5a..669decea64b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jun 7 22:13:59 UTC 2018
+# Wed Jul 11 19:19:46 UTC 2018
pkgbase = elm-platform
pkgdesc = Bundle of all core development tools for the Elm language.
pkgver = 0.18.0
- pkgrel = 3
+ pkgrel = 4
url = http://elm-lang.org
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = elm-platform
makedepends = patchelf
depends = gmp
depends = zlib
+ optdepends = nodejs: for elm-repl
conflicts = nodejs-elm
+ conflicts = elm-platform-bin
source = elm-compiler-0.18.0.zip::https://github.com/elm-lang/elm-compiler/archive/0.18.0.zip
source = elm-package-0.18.0.zip::https://github.com/elm-lang/elm-package/archive/0.18.0.zip
source = elm-make-0.18.0.zip::https://github.com/elm-lang/elm-make/archive/0.18.0.zip
diff --git a/PKGBUILD b/PKGBUILD
index 64ee3efbd400..24ccf8445032 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Lukas Werling <lukas.werling@gmail.com>
pkgname=elm-platform
pkgver=0.18.0
-pkgrel=3
+pkgrel=4
pkgdesc="Bundle of all core development tools for the Elm language."
arch=('i686' 'x86_64')
url="http://elm-lang.org"
license=('BSD3')
depends=('gmp' 'zlib')
+optdepends=('nodejs: for elm-repl')
makedepends=('stack-static' 'patchelf')
-conflicts=('nodejs-elm')
+conflicts=('nodejs-elm' 'elm-platform-bin')
source=(
elm-compiler-${pkgver}.zip::https://github.com/elm-lang/elm-compiler/archive/${pkgver}.zip
elm-package-${pkgver}.zip::https://github.com/elm-lang/elm-package/archive/${pkgver}.zip
@@ -27,7 +28,7 @@ sha256sums=('911109bbedf13c5a5c154ff8b60087b43cfd8be5e165df09b4e8f532a9f22fcd'
prepare() {
cd "$srcdir"
- ln -sf elm-compiler-${pkgver} elm-compiler
+ ln -sf compiler-${pkgver} elm-compiler
ln -sf elm-package-${pkgver} elm-package
ln -sf elm-make-${pkgver} elm-make
ln -sf elm-reactor-${pkgver} elm-reactor
@@ -36,8 +37,10 @@ prepare() {
build() {
cd "$srcdir"
+ mkdir -p .stack
- stack build --install-ghc
+ stack setup --stack-root "$PWD/.stack"
+ stack build --stack-root "$PWD/.stack"
binpath="$(stack path --local-install-root)/bin"
for bin in elm elm-make elm-package elm-reactor elm-repl; do