summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-06-20 19:17:30 +0200
committerbartus2021-06-20 19:22:29 +0200
commitdcbb79dea6b84d13e6b0cb1a0f4557ffec96ead5 (patch)
tree6dd8d546ae1e023bbdf9375afc71750960e46f90
parent021ca66f5b3a0b52c6c6c26001e867b9f7e82872 (diff)
downloadaur-dcbb79dea6b84d13e6b0cb1a0f4557ffec96ead5.tar.gz
Enable check() but ignore errors.
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e0e78066291..bc01914154da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -72,11 +72,11 @@ build() {
make -C build all
}
-# check() {
-# cd "$srcdir/build"
-# export PATH=$PATH:$PWD/fem/src
-# ctest -j$( grep -c ^processor /proc/cpuinfo )
-# }
+check() {
+ cd "$srcdir/build"
+ export PATH=$PATH:$PWD/fem/src
+ ctest $(grep -oP -- "-j\s*[0-9]+" <<< "${MAKEFLAGS}") || true
+}
package() {
make -C build DESTDIR="$pkgdir" install