summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Cromer2016-05-19 20:29:48 -0400
committerChris Cromer2016-05-19 20:29:48 -0400
commitea24154516e0c477b1e3de5f234f8b322e077e4e (patch)
tree23a5331a8c97527fbdb5ff93e244e002c8e4f677
downloadaur-ea24154516e0c477b1e3de5f234f8b322e077e4e.tar.gz
initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD49
-rw-r--r--elogind-docs.patch19
-rw-r--r--elogind-lrt.patch10
-rw-r--r--elogind.install9
5 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..375c0366b327
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Fri May 20 00:28:02 UTC 2016
+pkgbase = elogind-git
+ pkgdesc = The systemd project's logind, extracted to a standalone package
+ pkgver = 219.14.6d224ff
+ pkgrel = 1
+ url = https://github.com/wingo/elogind.git
+ install = elogind.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = libcap
+ makedepends = intltool
+ makedepends = libtool
+ makedepends = gperf
+ makedepends = gtk-doc
+ depends = dbus
+ depends = polkit
+ depends = libudev.so
+ provides = elogind
+ conflicts = elogind
+ options = !libtool
+ backup = etc/elogind/logind.conf
+ source = git+https://github.com/wingo/elogind.git
+ source = elogind-docs.patch
+ source = elogind-lrt.patch
+ sha256sums = SKIP
+ sha256sums = cafea7a13159dee700902e3837aab015d9521dfe122840faf2d909b5dc02229e
+ sha256sums = a9227ed4e97117ab5751de38c19813560a12f51379ccd882a89e7ef9842659ac
+
+pkgname = elogind-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa2b5baf2efe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Chris Cromer <chris@cromer.cl>
+# Contributor: artoo <artoo@manjaro.org>
+
+pkgname=elogind-git
+_pkgname=elogind
+pkgver=219.14.6d224ff
+pkgrel=1
+pkgdesc="The systemd project's logind, extracted to a standalone package"
+arch=('i686' 'x86_64')
+url="https://github.com/wingo/elogind.git"
+license=('GPL')
+depends=('dbus' 'polkit' 'libudev.so')
+makedepends=('git' 'libcap' 'intltool' 'libtool' 'gperf' 'gtk-doc')
+provides=('elogind')
+conflicts=('elogind')
+options=('!libtool')
+install=elogind.install
+backup=('etc/elogind/logind.conf')
+source=("git+${url}"
+ 'elogind-docs.patch'
+ 'elogind-lrt.patch')
+sha256sums=(SKIP
+ 'cafea7a13159dee700902e3837aab015d9521dfe122840faf2d909b5dc02229e'
+ 'a9227ed4e97117ab5751de38c19813560a12f51379ccd882a89e7ef9842659ac')
+
+prepare() {
+ cd $srcdir/$_pkgname
+ patch -Np 1 -i $srcdir/elogind-docs.patch
+ patch -Np 1 -i $srcdir/elogind-lrt.patch
+ sed -e "s|/bin/false|/usr/lib/elogind/elogind|" \
+ -i src/login/org.freedesktop.login1.service
+ autoreconf -vim
+}
+
+build() {
+ cd $srcdir/${_pkgname}
+ intltoolize
+ ./configure \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ --libexecdir=/usr/lib
+
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/elogind-docs.patch b/elogind-docs.patch
new file mode 100644
index 000000000000..4763be2e6d7f
--- /dev/null
+++ b/elogind-docs.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -253,16 +253,6 @@
+ dist_bashcompletion_DATA =
+ dist_zshcompletion_DATA =
+
+-dist_doc_DATA = \
+- README \
+- NEWS \
+- LICENSE.LGPL2.1 \
+- LICENSE.GPL2 \
+- LICENSE.MIT \
+- src/libelogind/sd-bus/PORTING-DBUS1 \
+- src/libelogind/sd-bus/DIFFERENCES \
+- src/libelogind/sd-bus/GVARIANT-SERIALIZATION
+-
+ @INTLTOOL_POLICY_RULE@
+
+ # ------------------------------------------------------------------------------
diff --git a/elogind-lrt.patch b/elogind-lrt.patch
new file mode 100644
index 000000000000..19055fa30944
--- /dev/null
+++ b/elogind-lrt.patch
@@ -0,0 +1,10 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -778,6 +778,7 @@
+
+ libelogind_core_la_LIBADD = \
+ $(UDEV_LIBS) \
++ -lrt \
+ libelogind-internal.la
+
+ if HAVE_ACL
diff --git a/elogind.install b/elogind.install
new file mode 100644
index 000000000000..9366e5332774
--- /dev/null
+++ b/elogind.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Add the following line to your pam greeter file:"
+ echo "session optional pam_elogind.so"
+ echo "/etc/pam.d/sddm-greeter, /etc/pam.d/lightdm-greeter, etc..."
+}
+
+post_upgrade() {
+ post_install $1
+}