summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkovax32018-10-28 19:03:43 +0100
committerkovax32018-10-28 19:03:43 +0100
commit57e27dfbaf43c2c0efe248b81c0ec25518dea7f4 (patch)
tree2cda03a2668ba5c00c981b6e6af1daf8dae35bc9
downloadaur-57e27dfbaf43c2c0efe248b81c0ec25518dea7f4.tar.gz
elokab file manager v0.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD63
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63fd5c146f9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = elokab-files-manager
+ pkgdesc = A lightweight file manager for Linux desktops built in Qt.
+ pkgver = 0.2
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ depends = qt5-svg
+ depends = file
+ depends = udisks2
+ optdepends = imagemagick
+ optdepends = ffmpeg
+ source = https://github.com/zakariakov/elokab-files-manager/archive/v0.2.tar.gz
+ md5sums = SKIP
+
+pkgname = elokab-files-manager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3269a48f85c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+#author: Abouzakaria <zkariakov@gmail.com>
+#Maintainer: kovax <kovax3@gmail.com>
+pkgname=elokab-files-manager
+pkgver=0.2
+pkgrel=1
+epoch=
+pkgdesc="A lightweight file manager for Linux desktops built in Qt."
+arch=( 'x86_64')
+url=""
+license=('GPL')
+groups=()
+depends=('qt5-svg' 'file' 'udisks2')
+makedepends=()
+checkdepends=()
+optdepends=('imagemagick' 'ffmpeg')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+#source=("$pkgname-$pkgver.tar.gz")
+source=(https://github.com/zakariakov/elokab-files-manager/archive/v$pkgver.tar.gz)
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake "elokab-files-manager.pro" \
+ PREFIX=/usr \
+ QMAKE_CFLAGS_RELEASE="${CFLAGS}"\
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+
+ make INSTALL_ROOT="${pkgdir}"/ install || return 1
+ find "$pkgdir" -type d -print0 | xargs -0 chmod -R 755
+ find "$pkgdir" -type f -print0 | xargs -0 chmod -R 644
+ chmod 755 "$pkgdir/usr/bin/elokab-fm"
+ chmod 755 "$pkgdir/usr/bin/elokab-fa"
+
+}