summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkovax32018-10-28 19:16:00 +0100
committerkovax32018-10-28 19:16:00 +0100
commit51b9b356aadae1da1b78bba89eccf32b607233f9 (patch)
tree4bfa49180f3a592198a85d31c1dd11688ae5e7eb
downloadaur-51b9b356aadae1da1b78bba89eccf32b607233f9.tar.gz
elokab terminal v0.3.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD63
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16f09462bda3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = elokab-terminal
+ pkgdesc = Lightweight terminal emulator program that supports the Arabic language
+ pkgver = 0.3.2
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ depends = qt5-svg
+ source = https://github.com/zakariakov/elokab-terminal/archive/v0.3.2.tar.gz
+ md5sums = SKIP
+
+pkgname = elokab-terminal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ae2201282d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+#Athor: Abouzakaria <zkariakov@gmail.com>
+#Maintainer: kovax3 <kovax@gmail.com>
+
+pkgname=elokab-terminal
+pkgver=0.3.2
+pkgrel=1
+epoch=
+pkgdesc="Lightweight terminal emulator program that supports the Arabic language"
+arch=( 'x86_64')
+url=""
+license=('GPL')
+groups=()
+depends=('qt5-svg')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/zakariakov/elokab-terminal/archive/v$pkgver.tar.gz" )
+
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake "elokabTerminal.pro" \
+ PREFIX=/usr \
+ QMAKE_CFLAGS_RELEASE="${CFLAGS}"\
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+
+ make INSTALL_ROOT="${pkgdir}"/ install || return 1
+ find "$pkgdir" -type d -print0 | xargs -0 chmod -R 755
+ find "$pkgdir" -type f -print0 | xargs -0 chmod -R 644
+ chmod 755 "$pkgdir/usr/bin/elokab-terminal"
+
+}