summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-11-04 15:27:03 +0300
committerCaleb Maclennan2023-11-04 15:27:03 +0300
commite1689f38f7fce99e3b46e3a3d0022c2136ec2e16 (patch)
treeb689ebbb63e2a47193931ed42430fb56073962ac
parent7b23bfa7dfdd4f42f1587fb78f7b6feae83b50d6 (diff)
downloadaur-e1689f38f7fce99e3b46e3a3d0022c2136ec2e16.tar.gz
upgpkg: elstob-font 2.101-1
upstream release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20a8b6e61759..404ef5b547ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
pkgbase = elstob-font
pkgdesc = A variable font for medievalists
- pkgver = 2.100
+ pkgver = 2.101
pkgrel = 1
url = https://github.com/psb1558/Elstob-font
arch = any
license = OFL
- source = https://github.com/psb1558/Elstob-font/releases/download/v2.100/Elstob_v2_100.zip
- sha256sums = 273a774ceffbb542f91e86c8a205ed2278d25604f14d353a70413b3e796753ba
+ source = https://github.com/psb1558/Elstob-font/releases/download/v2.101/Elstob_v2.101.zip
+ sha256sums = 43a1e1e55778842131b8900a64f7d1312f72fac15732a2b852a40c54cb42f0f6
pkgname = otf-elstob
provides = elstob-font
+ provides = otf-elstob-desktop
conflicts = elstob-font-variable
+ replaces = otf-elstob-desktop
pkgname = ttf-elstob
provides = elstob-font
+ provides = ttf-elstob-desktop
conflicts = elstob-font-variable
-
-pkgname = ttf-elstob-desktop
- provides = elstob-font
+ replaces = ttf-elstob-desktop
pkgname = ttf-elstob-variable
provides = elstob-font-variable
diff --git a/PKGBUILD b/PKGBUILD
index 32994ab554b1..1e1460463722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,34 @@
_name=elstob
pkgbase=$_name-font
-pkgname=(otf-$_name ttf-$_name ttf-$_name-desktop ttf-$_name-variable)
-pkgver=2.100
+pkgname=(otf-$_name ttf-$_name ttf-$_name-variable)
+pkgver=2.101
pkgrel=1
pkgdesc='A variable font for medievalists'
arch=('any')
url="https://github.com/psb1558/${pkgbase^}"
license=('OFL')
-source=("$url/releases/download/v${pkgver}/${_name^}_v${pkgver/./_}.zip")
-sha256sums=('273a774ceffbb542f91e86c8a205ed2278d25604f14d353a70413b3e796753ba')
+source=("$url/releases/download/v$pkgver/${_name^}_v$pkgver.zip")
+sha256sums=('43a1e1e55778842131b8900a64f7d1312f72fac15732a2b852a40c54cb42f0f6')
package_otf-elstob() {
- provides=("$pkgbase")
+ provides=("$pkgbase" "$pkgname-desktop")
conflicts=("$pkgbase-variable")
+ replaces=("$pkgname-desktop")
cd "${_name^}_font"
install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" otf/*.otf
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
}
package_ttf-elstob() {
- provides=("$pkgbase")
+ provides=("$pkgbase" "$pkgname-desktop")
conflicts=("$pkgbase-variable")
+ replaces=("$pkgname-desktop")
cd "${_name^}_font"
install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" ttf/*.ttf
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
}
-package_ttf-elstob-desktop() {
- provides=("$pkgbase")
- cd "${_name^}_font"
- install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" desktop/*.ttf
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" OFL.txt
-}
-
package_ttf-elstob-variable() {
provides=("$pkgbase-variable")
cd "${_name^}_font"