summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Greene2015-10-07 11:22:51 -0700
committerMichael Greene2015-10-07 11:22:51 -0700
commit2cbd6895203bc8c4993719873480439fc633560f (patch)
tree0bc642f1a71c1fff959e6123af22ab2f8d998c16
downloadaur-2cbd6895203bc8c4993719873480439fc633560f.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6cea2cd16b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = eluminance-git
+ pkgdesc = A fast photo browser, written in Python using EFL
+ pkgver = 0.9.r66
+ pkgrel = 1
+ url = https://github.com/DaveMDS/eluminance
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python-efl
+ depends = python-xdg
+ provides = eluminance
+ source = git+https://github.com/DaveMDS/eluminance.git
+ sha256sums = SKIP
+
+pkgname = eluminance-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8573ed95d2be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Michael Greene <mgreene@securityinnovation.com>
+
+pkgname=eluminance-git
+pkgver=0.9.r66
+pkgrel=1
+pkgdesc="A fast photo browser, written in Python using EFL"
+arch=('any')
+url="https://github.com/DaveMDS/eluminance"
+license=('GPL')
+depends=('python-efl' 'python-xdg')
+makedepends=('git')
+provides=('eluminance')
+source=('git+https://github.com/DaveMDS/eluminance.git')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ printf "%s.r%s" \
+ "$(cd ${srcdir}/eluminance; python setup.py --version)" \
+ "$(cd eluminance; git rev-list --count HEAD)"
+}
+
+build() {
+ cd "${srcdir}/eluminance"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/eluminance"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+} \ No newline at end of file