summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchengxuncc2019-12-08 21:54:13 +0800
committerchengxuncc2019-12-08 21:54:13 +0800
commit99cd2c37e818b49ed6583ee80701bafa4ea2cb1a (patch)
treeff1185c2c2084763c6b59c763420b205001567cf
parent7e01c9258a9ab4e2bb4437ad4b44f6fa008c83f5 (diff)
downloadaur-99cd2c37e818b49ed6583ee80701bafa4ea2cb1a.tar.gz
update download URL
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb47ce4cd76a..9f3901208ab4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = elvish-bin
pkgdesc = A friendly and expressive Unix shell.
pkgver = 0.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/elves/elvish
install = elvish.install
arch = x86_64
license = custom:2-clause BSD
depends = glibc
provides = elvish
- source = https://dl.elv.sh/elvish-linux-amd64-0.12.tar.gz
+ source = https://dl.elv.sh/linux-amd64/elvish-v0.12.tar.gz
source = LICENSE
- sha256sums = 3dabcce5b8c4c6a277ff5b31793dab728fef952180c82099de7303ee43a001bc
+ sha256sums = 20ef74019eb1318ec40656a08a9925e6f65075c7e988dfaed70b5420bf086c64
sha256sums = 1912e3785c0eb8d78e0ceed945b32596c11d0f9088aa5c1ad8f18f134f08c500
pkgname = elvish-bin
diff --git a/PKGBUILD b/PKGBUILD
index add82678a3e9..207421f21170 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Xuanwo <xuanwo.cn#gmail.com>
+# Maintainer: chengxuncc <chengxuncc@gmail.com>
pkgname=elvish-bin
pkgver=0.12
-pkgrel=1
+pkgrel=2
pkgdesc="A friendly and expressive Unix shell."
arch=('x86_64')
url="https://github.com/elves/elvish"
@@ -10,18 +11,18 @@ license=('custom:2-clause BSD')
provides=('elvish')
depends=('glibc')
source=(
- "https://dl.elv.sh/elvish-linux-amd64-${pkgver}.tar.gz"
+ "https://dl.elv.sh/linux-amd64/elvish-v${pkgver}.tar.gz"
"LICENSE"
)
sha256sums=(
- '3dabcce5b8c4c6a277ff5b31793dab728fef952180c82099de7303ee43a001bc'
+ '20ef74019eb1318ec40656a08a9925e6f65075c7e988dfaed70b5420bf086c64'
'1912e3785c0eb8d78e0ceed945b32596c11d0f9088aa5c1ad8f18f134f08c500'
)
install=elvish.install
package() {
# binary
- install -Dm755 elvish-linux-amd64-${pkgver} "${pkgdir}/usr/bin/elvish"
+ install -Dm755 elvish-v${pkgver} "${pkgdir}/usr/bin/elvish"
# LICENSE
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}