summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuoxi Wang2022-06-26 21:29:41 +0800
committerRuoxi Wang2022-06-26 21:29:41 +0800
commit98c3ef75b35a3bc8b70c648def75c7b944781920 (patch)
tree797266d763c15d8e77fd4935ba47ebca866f8020
downloadaur-98c3ef75b35a3bc8b70c648def75c7b944781920.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b096b3b1b532
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = elxocmcorekit
+ pkgdesc = CLI manager of Emulex HBAs in physical and virtual server deployments
+ pkgver = 14.0.505.14
+ pkgrel = 1
+ url = https://www.broadcom.com/products/storage/fibre-channel-host-bus-adapters/emulex-hba-manager
+ arch = x86_64
+ license = custom
+ options = !strip
+ source = file://elxocmcore-ubuntu18-22-14.0.505.14-1.tgz
+ sha256sums = 9630d6c77736db7430e43aca52db73709c70301008a01e23b4e6fdfd6b04ec3f
+
+pkgname = elxocmcorekit
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4596f8f53d9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Reese Wang <thuwrx10 at gmail dot com>
+
+pkgname='elxocmcorekit'
+pkgver=14.0.505.14
+pkgrel=1
+pkgdesc="CLI manager of Emulex HBAs in physical and virtual server deployments"
+arch=('x86_64')
+url="https://www.broadcom.com/products/storage/fibre-channel-host-bus-adapters/emulex-hba-manager"
+license=('custom')
+options=('!strip')
+source=("file://elxocmcore-ubuntu18-22-${pkgver}-${pkgrel}.tgz")
+sha256sums=('9630d6c77736db7430e43aca52db73709c70301008a01e23b4e6fdfd6b04ec3f')
+
+prepare() {
+ ar x elxocmcore-ubuntu18-22-${pkgver}-${pkgrel}/x86_64/ubuntu-20/elxocmcorekit_${pkgver}-${pkgrel}_amd64.deb
+}
+
+package() {
+ tar xf data.tar.xz -C "$pkgdir"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/"
+ mv "${pkgdir}/lib" "${pkgdir}/usr/"
+}