summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-12-23 23:26:05 +0100
committerAdrian Perez de Castro2020-12-23 23:26:05 +0100
commit8abf9ad0b6555554732992f55620277c17ac1c5d (patch)
treecd4705e3c6512eef521b0909ad9b100cab815696
parent99e9a812939e47cd5fe035167bb4559d2ce0376f (diff)
downloadaur-8abf9ad0b6555554732992f55620277c17ac1c5d.tar.gz
Bump to version 1.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09107264292c..e3f8e585e20d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = em-keyboard
pkgdesc = Command-line utility for referencing emoji characters by name
- pkgver = 0.0.7
- pkgrel = 3
- url = https://github.com/kennethreitz/em-keyboard
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/hugovk/em-keyboard
arch = any
license = custom:MIT
depends = python-docopt
depends = python-xerox
- source = https://github.com/kennethreitz/em/archive/v0.0.7.tar.gz
- sha512sums = f66775526d226c3029a9fb09cbcc18016ef87e8a16e56bd7afbfa2d8b436f9e54b5d4acd78bd79e3c8cc7306c6145d61ff35d637f211922e7110c9ec6fb781ce
+ depends = python-wheel
+ source = em-keyboard::git+https://github.com/hugovk/em-keyboard#tag=v1.0.0
+ sha512sums = SKIP
pkgname = em-keyboard
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218620e2fb38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 658ec8484069..61085d5d4ba0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: Adrián Pérez de Castro <aperez@igalia.com>
-pkgname='em-keyboard'
+pkgname=em-keyboard
pkgdesc='Command-line utility for referencing emoji characters by name'
-pkgver='0.0.7'
-pkgrel='3'
-url='https://github.com/kennethreitz/em-keyboard'
-license=('custom:MIT')
-arch=('any')
-depends=('python-docopt' 'python-xerox')
-source=("https://github.com/kennethreitz/em/archive/v${pkgver}.tar.gz")
-sha512sums=('f66775526d226c3029a9fb09cbcc18016ef87e8a16e56bd7afbfa2d8b436f9e54b5d4acd78bd79e3c8cc7306c6145d61ff35d637f211922e7110c9ec6fb781ce')
+pkgver=1.0.0
+pkgrel=1
+url=https://github.com/hugovk/em-keyboard
+license=(custom:MIT)
+arch=(any)
+depends=(python-docopt python-xerox python-wheel)
+source=("${pkgname}::git+${url}#tag=v${pkgver}")
+sha512sums=(SKIP)
package () {
- cd "${pkgname}-${pkgver}"
- 2to3 --nobackups --write --no-diffs em
+ cd "${pkgname}"
python3 setup.py install --optimize=1 --root="${pkgdir}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}