summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-08-19 10:13:04 +0200
committerhaawda2018-08-19 10:13:04 +0200
commit9c0d550a442631392db35cf1c540a7e03162394a (patch)
tree946cc541128573116a4c8c9849843b080b321083
parentf617fd51cc1f8be439f4f414056f851a016b1699 (diff)
downloadaur-9c0d550a442631392db35cf1c540a7e03162394a.tar.gz
adopted
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15e08be041cb..5fbf6522af15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Tue Apr 25 17:42:08 UTC 2017
pkgbase = emacs-ag
- pkgdesc = An Emacs frontend to The Silver Searcher
+ pkgdesc = An Emacs frontend to The Silver Searcher (binary name ag)
pkgver = 0.47
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Wilfred/ag.el
arch = any
license = GPL3
depends = emacs
depends = emacs-dash
depends = emacs-s
- source = https://github.com/Wilfred/ag.el/archive/0.47.tar.gz
- sha256sums = SKIP
+ source = emacs-ag-0.47.tar.gz::https://github.com/Wilfred/ag.el/archive/0.47.tar.gz
+ md5sums = 930693d5e34da67d7f96f3aece2fab5b
pkgname = emacs-ag
diff --git a/PKGBUILD b/PKGBUILD
index 069163d84833..4efaa360292c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-ag
pkgver=0.47
-pkgrel=1
-pkgdesc="An Emacs frontend to The Silver Searcher"
-arch=(any)
+pkgrel=2
+pkgdesc="An Emacs frontend to The Silver Searcher (binary name ag)"
+arch=('any')
url="https://github.com/Wilfred/ag.el"
license=('GPL3')
depends=('emacs' 'emacs-dash' 'emacs-s')
-source=("https://github.com/Wilfred/ag.el/archive/${pkgver}.tar.gz")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Wilfred/ag.el/archive/$pkgver.tar.gz")
+md5sums=('930693d5e34da67d7f96f3aece2fab5b')
build() {
- cd "${srcdir}/ag.el-${pkgver}"
+ cd "$srcdir"/ag.el-$pkgver
emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/ag.el-${pkgver}"
- mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/ag/"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/ag/"
+ cd "$srcdir"/ag.el-$pkgver
+ mkdir -p "$pkgdir"/usr/share/emacs/site-lisp/ag/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/ag/
}