summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-25 13:43:55 -0400
committerAlex Whitt2017-04-25 13:43:55 -0400
commitf617fd51cc1f8be439f4f414056f851a016b1699 (patch)
tree3003878ed737c6d58e089525ce0ce1752f73e053
downloadaur-f617fd51cc1f8be439f4f414056f851a016b1699.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15e08be041cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Apr 25 17:42:08 UTC 2017
+pkgbase = emacs-ag
+ pkgdesc = An Emacs frontend to The Silver Searcher
+ pkgver = 0.47
+ pkgrel = 1
+ url = https://github.com/Wilfred/ag.el
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-dash
+ depends = emacs-s
+ source = https://github.com/Wilfred/ag.el/archive/0.47.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-ag
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..069163d84833
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-ag
+pkgver=0.47
+pkgrel=1
+pkgdesc="An Emacs frontend to The Silver Searcher"
+arch=(any)
+url="https://github.com/Wilfred/ag.el"
+license=('GPL3')
+depends=('emacs' 'emacs-dash' 'emacs-s')
+source=("https://github.com/Wilfred/ag.el/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/ag.el-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/ag.el-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/ag/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/ag/"
+}