summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-09-03 16:46:21 +0200
committersballert2018-09-03 16:46:21 +0200
commitfbf720a2e9b3ca32e3c1a6aab63accf7e0731053 (patch)
tree413dfa6f8f2f7b584c2e24c0fb6a62e6238e66a2
downloadaur-fbf720a2e9b3ca32e3c1a6aab63accf7e0731053.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fe7a52ef059
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = emacs-all-the-icons-dired-git
+ pkgdesc = Adds dired support to all-the-icons
+ pkgver = r31.980b774
+ pkgrel = 1
+ url = https://github.com/jtbm37/all-the-icons-dired
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-all-the-icons
+ provides = emacs-all-the-icons-dired
+ conflicts = emacs-all-the-icons-dired
+ source = git+https://github.com/jtbm37/all-the-icons-dired.git
+ sha256sums = SKIP
+
+pkgname = emacs-all-the-icons-dired-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9f3ced894fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="jtbm37"
+_gitrepo="all-the-icons-dired"
+
+pkgname=emacs-all-the-icons-dired-git
+pkgver=r31.980b774
+pkgrel=1
+pkgdesc="Adds dired support to all-the-icons"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-all-the-icons')
+makedepends=('git')
+provides=('emacs-all-the-icons-dired')
+conflicts=('emacs-all-the-icons-dired')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}