summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsballert2018-07-31 16:00:50 +0200
committersballert2018-07-31 16:00:50 +0200
commit9a4b8c9fba187ebf0b33ab663b4801a4f8d6b7d9 (patch)
treeae2257a2ec092a089c96c20935820a4ed6800a38
downloadaur-9a4b8c9fba187ebf0b33ab663b4801a4f8d6b7d9.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5fce3211492
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = emacs-all-the-icons-ivy-git
+ pkgdesc = all-the-icons.el for Ivy/Counsel
+ pkgver = r16.52b3f4a
+ pkgrel = 1
+ url = https://github.com/asok/all-the-icons-ivy
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs-all-the-icons
+ provides = emacs-all-the-icons-ivy.el
+ source = git+https://github.com/asok/all-the-icons-ivy.git
+ md5sums = SKIP
+
+pkgname = emacs-all-the-icons-ivy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05db030b667e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+pkgname=emacs-all-the-icons-ivy-git
+pkgver=r16.52b3f4a
+pkgrel=1
+pkgdesc="all-the-icons.el for Ivy/Counsel"
+arch=('any')
+url="https://github.com/asok/all-the-icons-ivy"
+license=('GPL3')
+depends=('emacs-all-the-icons')
+makedepends=('git')
+provides=('emacs-all-the-icons-ivy.el')
+source=("git+https://github.com/asok/all-the-icons-ivy.git")
+md5sums=('SKIP')
+_gitname="all-the-icons-ivy"
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitname"
+ emacs -batch -L . -f batch-byte-compile *.el || true
+}
+
+package() {
+ cd $_gitname
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/all-the-icons-ivy"
+ install -m644 all-the-icons-ivy.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/all-the-icons-ivy/"
+}