summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-02-17 20:01:14 +0100
committerhaawda2019-02-17 20:01:14 +0100
commit1f26dee83250c1138c4aca6bfd8f877b43c2a16c (patch)
tree74d55a575ffc4d7fd867d6264d7d55336e0171d0
parenta657520a14009cb3d520862e6a850494a3ed290b (diff)
downloadaur-1f26dee83250c1138c4aca6bfd8f877b43c2a16c.tar.gz
small cosmetical changes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04e2f5940ce6..c266d3b8f317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Thu May 4 18:13:46 UTC 2017
pkgbase = emacs-anzu
- pkgdesc = Emacs Port of anzu.vim
+ pkgdesc = Minor mode which displays current match and total matches information in the mode-line
pkgver = 0.62
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/syohex/emacs-anzu
install = emacs-anzu.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 051c78db2608..c3ccbcf3203d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
_pkgsrcname=emacs-anzu
_pkgmaintainer=syohex
_pkgdestdirname=anzu
_versionprefix=
pkgver=0.62
-pkgrel=1
-pkgdesc="Emacs Port of anzu.vim"
+pkgrel=2
+pkgdesc="Minor mode which displays current match and total matches information in the mode-line"
pkgname=emacs-${_pkgdestdirname}
-arch=(any)
+arch=('any')
url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
license=('GPL3')
depends=('emacs')
@@ -17,12 +18,12 @@ sha256sums=('9f91077d12bffc2d30640dfc5a5b627139d03c06bee9335f5df6977e121a8f99')
install=${pkgname}.install
build() {
- cd "${srcdir}/${_pkgsrcname}-${pkgver}"
+ cd ${_pkgsrcname}-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
}
package() {
- cd "${srcdir}/${_pkgsrcname}-${pkgver}"
- mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
- install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/${_pkgdestdirname}/"
+ cd ${_pkgsrcname}-${pkgver}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/
}