summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-02-17 20:01:52 +0100
committerhaawda2019-02-17 20:01:52 +0100
commit4fc6a8de198fad7478b0fc3de94ff409783fb4ad (patch)
tree8fad142e04207d81ea75ca0b5885dbf84c19ca6d
parent7b304b5f86f4d1f4d0000e414a5b0b039ea9dfd5 (diff)
downloadaur-4fc6a8de198fad7478b0fc3de94ff409783fb4ad.tar.gz
Adopted, rewritten pkgver function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4579770c6627..fd1b7c01c389 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-anzu-git
pkgdesc = Emacs Port of anzu.vim
- pkgver = r261.e6c56ca
+ pkgver = 0.62r10.ge6c56ca
pkgrel = 1
url = https://github.com/syohex/emacs-anzu
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 6584070b49a0..e2e90f9fa1f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: sballert <sballert@posteo.de>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
_gituser="syohex"
_gitrepo="emacs-anzu"
pkgname=emacs-anzu-git
-pkgver=r261.e6c56ca
+pkgver=0.62r10.ge6c56ca
pkgrel=1
pkgdesc="Emacs Port of anzu.vim"
url="https://github.com/${_gituser}/${_gitrepo}"
@@ -19,7 +20,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$_gitrepo"
- printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ git describe --tags --long | sed 's+-+r+' | tr - .
}
build() {
@@ -29,6 +30,6 @@ build() {
package() {
cd "$_gitrepo"
- install -d "$pkgdir"/usr/share/emacs/site-lisp/anzu/
- install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/anzu/
+ install -d "$pkgdir"/usr/share/emacs/site-lisp
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp
}